Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 20 of 26 Posts

·
Premium Member
Joined
·
77 Posts
Discussion Starter · #1 ·
this morning i went to install another tune and when it was counting down from 15 at the end of the tune it froze, now when i try to do anything with it it has this weird thumping sound in the dash and wont go past the first screens or any thing. also the ppe screen will flash dark to light:booboo:help
 

·
Registered
Joined
·
2,379 Posts
does the truck start? and run
 

·
Registered
Joined
·
2,379 Posts
well sucks buddy. but you need to have her towed to a dealer to have the ECM reflashed and you need to send the PPE back to PPE to have it unlocked
 

·
Registered
Joined
·
2,379 Posts
i did it to myself also. dont feel bad. it costs about 100 bucks to have the reflash. well thats what it cost me anyways. try unhooking your batteries for 30mins and then try it. but i i doubt it will work
 

·
Premium Member
Joined
·
331 Posts
I know when uploading a tune on my SS crashes I can just unplug the battery for a few mins and it's fine. Worse case maybe need it reflashed.
 

·
Premium Member
Joined
·
77 Posts
Discussion Starter · #10 ·
the ecm just needs a reflash or a totally new unit? this sucks never had this problem. i can put head gaskets in myself but throw a ecm problem at me and bam im the idiot.
 

·
Registered
Joined
·
2,379 Posts
you ecm just needs a reflash. thats all the ECM is not bad
 

·
Registered
Joined
·
2,379 Posts
i did the samething i did my head gaskets and then tuned my truck and then i changed tunes and the tuner cut out on me and bammm no nothing.
 

·
Premium Member
Joined
·
77 Posts
Discussion Starter · #13 ·
same thing ahhh, o well i got to drive my truck for at least a month befor this
 

·
Registered
Joined
·
2,379 Posts
i would ditch the PPE like i am doign and get EFI this way you can reflash your ECM by yourself. you just load the stock log file back into the ECM
 

·
Premium Member
Joined
·
77 Posts
Discussion Starter · #15 ·
that was my plan after i make up a little money after head gaskets
 

·
Registered
Joined
·
67 Posts
This happened to me also, i must have gotten lucky cause all i did was wait a couple minutes plug the tuner back in, put it back to stock then loaded the tune back in and it was fine, i guess i got lucky LOL, good luck man!
 

·
Its just a worktruck
Joined
·
13,908 Posts
go into the diagnostic menu and select return to stock. Not in the tuning menu. What did you have plugged in? cell charger maybe?
 

·
Premium Member
Joined
·
77 Posts
Discussion Starter · #19 ·
had nothing plugged tried to go to stock charging batt now hopefuly thats it
 

·
Registered
Joined
·
2,379 Posts
does your seciruty light flash at you when the key is on or when you open the door
 
1 - 20 of 26 Posts
Top