Chevy and GMC Duramax Diesel Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
183 Posts
Discussion Starter #1
Ok got a problem that i hope someone can help me with..... recently i have been reading up on converting the dash lights to colored leds...so tonight i decided to take the gauge cluster out and look at it....i took it out very carefully and it came out quite easy.....i brought it inside took the glass off but decided it was too much work to take the needles and the overlay off so i said the hell with it and decided to put it back in.....so just as careful i put it back in and everything appeared to work properly...until i noticed an engine light on and half my speedo is a little brighter than the other half....WTF...i checked the engine light and it said MIL malfunction and Glo Plug Indicator malfunction but like i said everything appeared to be working....so i cleared the codes and hopefully tmr am when it is cold i get a glo plug inticator....anybody have any idea what i did wrong...as far as the light issue goes how did an led blow/get dimmer? :help I did unplug/plug the cluster in with the key on the acc. position because you have to put the shifter in 1st gear to get to the plug to unplug in and remove the cluster.....somebody please help the dimmer speedo is really pissin me off on the ride home tonight
 

·
Registered
Joined
·
44 Posts
It is likely you jarred something loose taking it out, or putting it back in, trust me it doesn't take much. I have repaired dozens of those gage clusters for various reasons, stepper motors or just lights. Just take it back out, take the needles off and make sure all the lights are snug and not partially lifted from the board.
 

·
Registered
Joined
·
183 Posts
Discussion Starter #3
ooo ok cool ya i plan on attempting, tho im kinda scared now, to convert to leds so i guess when i take it out again ill check it out.....i just wanted to make sure that i didnt blow anything...i mean that is the only thing that appears wrong all the other lights, gauges, indicator lights seem to be fine but one light in the middle doesnt appear right so maybe your right just jarring it around may have caused it to not light properly or go out....you ever have any problems with the CEL coming on after you unplug the cluster tho? idk why mine did....
 

·
Registered
Joined
·
44 Posts
Never had the CEL problem, but i will usually get the assembly out to where i can put it back in park and kill the key, or i just disconnect the battery. Depends on if i can get the cluster to cooperate, and what kind of time i have.
 

·
Registered
Joined
·
183 Posts
Discussion Starter #5
ok im sure thats y the light was on because the key was on next time ill be sure to make sure its off when i unplug/plug the cluster in hopefully clearing the CEL will solve the problem and it wont come back on...one more quick question...when taking the needles off and on how do i make sure i put them on exactally in the correct orientation? do they only go on one way? just want to make sure that the gauges will be calibrated correctly...sorry to be a pain i appreciate the quick replies
 

·
Registered
Joined
·
44 Posts
No problem, to take the needles off put a dinner fork under the needle gently appling some upward pressure and spin counterclockwise and it will pull off pretty easy. when you put them back on, align the needle at the center of the scale (so for a generic example if speedo is 0-120mph put needle at 60mph) then push the needle on and wind it back to the lowest point so again speedo at the bottom tick mark, or zero. They can be pretty tricky to get just right, i have found that with the battery, fuel, and other small needles it is hard to get them perfect, you just have to know where they normally indicate and determine if you have them right. The tach and the speedo are a bit easier to line up, and there is usually a little bit of error built in with those anyway. If you have a GPS you can check the speedo for accuracy and adjust accordingly. I have done some with no problem and some i have realigned 5 times, it just takes a steady hand and some patience. Happy fixing!!!
 

·
Registered
Joined
·
183 Posts
Discussion Starter #7
oo man what did i get myself into lol thanks alot i appreciate it hopefully everything will work out alright...just driving home tonight after this happened it was driving me nuts to see half the speedo brighter than the over lol
 

·
Registered
Joined
·
44 Posts
Trust me, not that hard just take your time. If i lived closer i would just fix it for you. The good part for locals around here is i work cheap, and beer or whiskey can normally be proper forms of payment
 

·
Registered
Joined
·
426 Posts
Trust me, not that hard just take your time. If i lived closer i would just fix it for you. The good part for locals around here is i work cheap, and beer or whiskey can normally be proper forms of payment
Shucks - I wished I were a local. I'd jump at you changing every dash light to an LED and I'd lower your bar tab somewhat...:drink
 

·
Registered
Joined
·
183 Posts
Discussion Starter #10
hell ya thats how we are around here too haha some budwiser and jack and well fix anything haha ive got alot of plans this coming spring so lol next is installation of my boost and pyro they should be in any day now....i know how do install them but i have to find someone to give me a hand in tapping the manifold and intake...just dont wanna screw that up lol i see youve got the cobalts too how you like them? thats what i decided to go with....and thats part of the reason why i wanna change my dash lights to blue so they sorta match
 

·
Registered
Joined
·
183 Posts
Discussion Starter #11
haha hell ya davis ill be down to charlotte in may for the race if you wanna get together haha btw got some nice white GMCs in NC mine came from wilkesboro
 

·
Registered
Joined
·
44 Posts
have not fully hooked up the gages, i have same fear with the drilling and tapping thing, i know i could just take the manifold off to be safe, but that just sounds time consuming, and time is something i have not had much of, but i am thinking i will make time this weekend and just bite the nerve racking bullet. But who knows i may want to switch my bulbs too, i guess we will see.
 

·
Registered
Joined
·
183 Posts
Discussion Starter #13
haha ya keep in touch and ill do the same....diesel manor has good instructions that ive found for gauge installation....theres a couple guys around here with diesels im gunna bug them and see if they can give me a had for a few beers lol
 

·
Registered
Joined
·
426 Posts
haha hell ya davis ill be down to charlotte in may for the race if you wanna get together haha btw got some nice white GMCs in NC mine came from wilkesboro
Yeah - I stuck you on my buddy list for reference. Maybe May will be kind to us and we can get together.

Yours is a nice rig. Nothing like a white GMC 2500HD when she's all cleaned up.

Regards,
Keith
 

·
Registered
Joined
·
426 Posts
have not fully hooked up the gages, i have same fear with the drilling and tapping thing, i know i could just take the manifold off to be safe, but that just sounds time consuming, and time is something i have not had much of, but i am thinking i will make time this weekend and just bite the nerve racking bullet. But who knows i may want to switch my bulbs too, i guess we will see.
The pyro isn't so bad - I did mine and idled the engine while I drilled and tapped the exman. Sounded really bad until I got the probe in place...
 

·
Registered
Joined
·
183 Posts
Discussion Starter #16
thanks alot yours is pretty nice lookin yourself..... i had to look twice at your avatar thought it was mine for a min lol but ya i gotta pretty good grasp on how to install em just want someone else there if possible....so this am i did get my glo plug indicator light so i take it the CEL is cleared...now tonight i am gunna rip the cluster apart again and check it out...had to get up at 530 and plow this am and the damn thing is driving me crazy there is no way i can wait to fix this lol
 
1 - 16 of 16 Posts
Top