Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys first of all i must give a big thanks to a lot of you guys although i have not posted before i have leaned quite a bit about my duramax and fixes from a lot of you on here.


So i have what appears to be excessive coolant pressure and at first i thought fore sure the HGs had gone but i have another interesting thing happening...

so to start i have no appearance of coolant in the oil and no smoke.

i have done the cheap trys such as new expansion tank cap and new thrm stats.

this is what i am seeing, if i take the cap off and run the truck there is no bubbles and no burping, instead the coolant level slowly rises untill it spills out over the top. with the cap on it holds its level.

i was loosing some coolant and thought for sure it was coming out the tube i now see that my water pump is starting to weep (ugh).

it seems to me that it is not the HGs but there is some kind of blockage in the system and the water pump is fighting that and forcing it back up the system creating the pressure. truck runs at temp. I just put a bottle on the overflow tube to see how much i am lossing there driving around.

just looking for some insight or some ideas.

thanks guys
Ian
 

·
Registered
Joined
·
2 Posts
Hey guys first of all i must give a big thanks to a lot of you guys although i have not posted before i have leaned quite a bit about my duramax and fixes from a lot of you on here.


So i have what appears to be excessive coolant pressure and at first i thought fore sure the HGs had gone but i have another interesting thing happening...

so to start i have no appearance of coolant in the oil and no smoke.

i have done the cheap trys such as new expansion tank cap and new thrm stats.

this is what i am seeing, if i take the cap off and run the truck there is no bubbles and no burping, instead the coolant level slowly rises untill it spills out over the top. with the cap on it holds its level.

i was loosing some coolant and thought for sure it was coming out the tube i now see that my water pump is starting to weep (ugh).

it seems to me that it is not the HGs but there is some kind of blockage in the system and the water pump is fighting that and forcing it back up the system creating the pressure. truck runs at temp. I just put a bottle on the overflow tube to see how much i am lossing there driving around.

just looking for some insight or some ideas.

thanks guys
Ian
I’m having the same problem, I don’t see anyone’s comments or reply’s to it, was it headgaskets or the radiator. Thank you in advance.
 

·
Premium Member
Joined
·
3,696 Posts
Drive the truck and check the upper radiator hose after it sits overnight. If the hose is hard the next morning, it is almost certainly HGs.
 

·
Registered
Joined
·
2 Posts
Yeah I checked mine two days later and it was still hard. Not a possibility it is a blocked heater core or bad thermostat is it?
Mine was the radiator come to find out. I’d flush it really good and try it after that. I know people who have done headgaskets and it was the radiator. It’s the dex cool coolant that causes these issues for whatever reason from what I’ve heard. But again it’s kind of a long shot.
 

·
Registered
2004,Chevy duramax 6.6L, diesel
Joined
·
21 Posts
It is a good possibility I had water in it and flushed it until it was almost clear then I added that radiator flush in it and drove roughly 6 hours when I drained it it was pretty rustic looking so maybe I’ll have to do that a few times to get it all out thanks I will try it
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top