Chevy and GMC Duramax Diesel Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
1,034 Posts
Discussion Starter #1
Ok guys im getting pissed this hid kit I bought is not working, when I start my truck at night I have the automatic headlights and some times the drivers side hid wont turn on it just does a quick buzz, so then I have to manually turn them on like 10+ times till I can get it to turn on if it even will, I checked all the connections an their snug and tight, I literally only have like 20mins on this kit, and the guy I bought it from is being a douche and wont help me out at all.

Things I have done:
Changed the stock 15amp fuse to a 30amp
Removed the DRL Fuse
Brand new batteries for the truck
Here is the kit I purchased




Im now looking at this kit but have questions, what is this "box" connected to the ballast? Like a built in relay or what? An this guy will give me a lifetime warranty so im planning on buying this kit an hoping like hell it wont give me any problems.



Any help would be appreciated, only thing I have in the truck that draws power would be my edge monitor but that shouldnt draw tons of amperage would it?
 

·
Registered
Joined
·
239 Posts
My hidS are acting like that. When the truck sits for awhile my passenger side one won't come on until I manually turn them off then back on but I only have to do it once after that its all good and if the truck hasn't been sitting long all works normal. I'm going to try and run a stand alone relay and see what happens
 

·
Registered
Joined
·
1,391 Posts
did you uses dieletric grease on the connections? Why not get a DDM kit like most guys here? I thought that's what you had
 

·
Registered
Joined
·
2,416 Posts
I used the cheap chinese ones(most digital hids are anyways) from ebay on my 1500. $30 and a year later theyre still working.
Sounds like the ballast is junk. Any warranty?
 

·
Registered
Joined
·
1,034 Posts
Discussion Starter #5
No not a DDM kit. I used grease, an because this kit was only $40 an the guy came to me, he said their is a 2 yr warranty if he installs them but wanted $25 to install so I said no.
 

·
Registered
Joined
·
239 Posts
Mine are ddm
 

·
Registered
Joined
·
239 Posts
Yea that's what I was thinking figured I would try make a stand alone relay first and then if that dosnt work order a new set and just have a Spare.
 

·
Registered
Joined
·
1,034 Posts
Discussion Starter #9
Can the ballast go bad after like 20mins of use?
 

·
Registered
Joined
·
82 Posts
I bought a similar looking kit last year ($45/pr, chinese, no brand name) at an expo and nothing worked when I plugged them in. When I used some loose wires and jumped them off a separate battery they worked fine, so thought maybe the connectors are defective, but no clue yet. Still sitting in the garage. YGWYPF.
 

·
Registered
Joined
·
1,391 Posts
return this kit? You were sold a defective kit
 

·
Registered
Joined
·
79 Posts
I would try switching the ballasts and see if the problem stays on the same side or not... Then u will know if its the ballast or not.... That way if it is something wired you don't have to buy a second kit and have it do the same thing.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
2,416 Posts
I bought a similar looking kit last year ($45/pr, chinese, no brand name) at an expo and nothing worked when I plugged them in. When I used some loose wires and jumped them off a separate battery they worked fine, so thought maybe the connectors are defective, but no clue yet. Still sitting in the garage. YGWYPF.
I know with mine you can plug the trucks bulb harness in two ways. At first the first one I connected didnt work. Just had to turn the harness around to reverse the polarity and they worked fine. Could be the case for you :thinkkkk
 
1 - 15 of 15 Posts
Top