Chevy and GMC Duramax Diesel Forum banner

1 - 13 of 13 Posts

·
Boom goes the Dynamite
Joined
·
1,123 Posts
Discussion Starter #1
So I tried the search the bar and couldnt find my answer, but just bought DDM kits and my lows work great but sometimes I notice I have to flip my high beams on a few times to get them to kick on, any reason or fix for this and once they are on they are great, thanks in advance guys!
 

·
Registered
Joined
·
2,538 Posts
I had just noticed while driving to the airport before I left, so I haven't had a chance to dig into it either. I figure i'll probably start with unplugging everything and checking the connections for signs of corrosion starting and my mounting locations of the ballasts for rigidity. Probably doesn't help ya much, but know that you aren't alone haha :drink
 

·
Boom goes the Dynamite
Joined
·
1,123 Posts
Discussion Starter #3
Sounds right it was weird in the parking lot couldnt get them started driving down a bumpy ass road and i tried them and they turned right on seems kinda ass backwards to me?
 

·
Registered
Joined
·
271 Posts
Do you have a harness on your kit or just plugged direct into the factory plug? I have found that having a harness kit helps a ton with these little bugs, they are about 15$
 

·
Registered
Joined
·
2,538 Posts
^they just won't come on the first time you hit the switch, second time they light right up. Doesn't happen all the time to me, dunno about OP
 

·
Registered
Joined
·
2,130 Posts
relay kit should solve your problem

probably not getting enough amperage over the factory wiring to fire the bulb
 

·
Administrator
Joined
·
8,818 Posts
if you want to have the in lows and highs...did you do the all on mod or just the hi/low mod? you will be in the dark for a short time if you dont have a relay to keep the lows on when the highs come on.

FWIW, make sure the ballasts are mounted SOLID! I had a cheap set killing my truck (truck would shut off going down the road). This was mostly from the ballast moving. You could have gotten a bad or intermittent ballast too.
 

·
I STILL DGAF
Joined
·
9,061 Posts
I'd be surprised if a relay did anything. Like he said mount the ballast firmly^^.

I had the all on mod on my old lbz and never once did the highs fail to come on with every other bulb lit on the truck. 6 in all........
 

·
Registered
Joined
·
89 Posts
One of my lows wouldn't come on every once in a while so I replaced the ballast and that fixed the problem

Sent from my DROIDX using AutoGuide App
 
1 - 13 of 13 Posts
Top