Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 4 of 4 Posts

·
Registered
Joined
·
159 Posts
Discussion Starter · #1 ·
What could be the issue with my horn? I sounds so wimpy! ANy help?
 

·
Registered
Joined
·
779 Posts
Water in it, or bad ground........?
 

·
Premium Member
Joined
·
5,057 Posts
I had the same issue. One of your horns is a low freq and one a high freq and one is most likely not working.

I purchased two new horns on eBay as a hi/low set. They were generic horns. I think I paid $25 for the two of them. I had to adapt the power wife to a spade connector after cutting off the factory plug.

https://www.ebay.com/itm/120DB-Pair...028108?hash=item5b4c2ccbcc:g:OLEAAOSws59c9P7-

I pulled the tire and fender liner on each side to get easy access to the factory horn to remove it and bolt he new one on.

Afterwards it sounded like new again.
 

·
Registered
Joined
·
159 Posts
Discussion Starter · #4 · (Edited)
I had the same issue. One of your horns is a low freq and one a high freq and one is most likely not working.

I purchased two new horns on eBay as a hi/low set. They were generic horns. I think I paid $25 for the two of them. I had to adapt the power wife to a spade connector after cutting off the factory plug.

https://www.ebay.com/itm/120DB-Pair...028108?hash=item5b4c2ccbcc:g:OLEAAOSws59c9P7-

I pulled the tire and fender liner on each side to get easy access to the factory horn to remove it and bolt he new one on.

Afterwards it sounded like new again.
Do these at least have some bass in them? man my truck sounds like a freaking moped right now
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top