Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
My truck won't start. Just cleaned the tank and put new filter on. Truck ran for a while but now won't even start. I even replaced fuel lines going to and from filter housing. Not sure what is going on. Getting really frustrated because I can't forsure diagnose the problem but if anyone has any it would be appreciated
 

·
Registered
Joined
·
250 Posts
Have you checked lines coming in and out of ficm to see if you're getting fuel there? Bled the system really good? I had to bleed the system several times when I disconnected lines when cleaning injectors to get it running.
 

·
Registered
Joined
·
250 Posts
Also make sure oring came off with old filter. If they're double stacked will suck air in.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #4 ·
Yeah I made sure filter was good? How exactly do I check fuel going in and out of ficm??
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #6 ·
Ok so I get it started after a lot of cranking. Runs ok but not good. After I stop driving it is kind of smoking on the side of fuel filter but I can't seem to find the source! If I try to start it again it asks like it is losing its prime totally and won start. It must be sucking air but can't find where at all
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #7 ·
I have a lift pump also so it shouldn't lose its fuel prime unless it's sucking air
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top