Chevy and GMC Duramax Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
143 Posts
Discussion Starter #1
I have a problem with my HVAC. All of the controls work fine, except that there is no air blowing out of the vents at all. I checked all of the fuses and they seem to be fine. I read a thread about a blower motor resistor that might be causing the problem. Unfortunately I do not know where the blower motor is located. Does this sound like it might be cause by a failure of the blower motor resistor. If so could you locate me to where it is so I can check it. Or if you have any other ideas. Thanks in advance for all the help this site is the best.

Kristopher Lemon
 

·
Premium Member
Joined
·
17,806 Posts
On the passenger side at the lower part of the dash there is a huge cover that hides everything-- remove the cover and under the glove box area- you will see a black box with 5-7 wires-- that is the resistor. Be sure to inspect the wires and connector-- replace if burnt at all. :)
 

·
Registered
Joined
·
785 Posts
My problem was the opposite, the fan ran all the time, even with the key off! Found the resistor as described above, pulled it out, there had been enough moisture to cause rust to form between two of the terminals, one of them being hot all the time, the other to the fan motor. Cleaned all of the rust out, smeared some dielectric grease on the terminals and out it back together. Have not had a problem since.
 

·
Registered
Joined
·
38 Posts
had similar issues...changed the fan first...learned that was not the issue....resistor...could not find at any part store...got from dealership and presto change - o. fixed!
 
1 - 4 of 4 Posts
Top