Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 7 of 7 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter · #1 ·
Just got my truck back two days ago from $1400 and a month out of commision. Replaced a broken flywheel, cracked torque converter, and put in new seal/bushing and pump gaskets. I just icepicked my #2 and #7 injector connectors and I'm still have the same random stalling issue and trouble getting it to stay running when it's cold. I checked the ficm bracket and the wires are fine. To top it all off I now have a "service brake system" along with a "range shift inhibited" message. My only forward gear is 4th and it clunks going into gear. The truck is just running like total crap and I don't know what to do.... ideas??
 

·
Registered
Joined
·
1,075 Posts
nsbu switch
 

·
Registered
Joined
·
214 Posts

·
Registered
Joined
·
214 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter · #5 · (Edited)
I found the problem. Looks like my front driveshaft snagged a wire. Could someone tell me where this wire is supposed to go? It branches off on top of the transfercase and it goes forward towards The large connector on the trans (nsbu switch?) I want to say it taps into the large wire loom in the upper part of the pic

 

·
Registered
Joined
·
87 Posts
Discussion Starter · #6 ·
I think this is where the wire came from:

Now I have to pray that I can figure out how to splice the proper wires back in
 
1 - 7 of 7 Posts
Top