Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Vote for the Site Favourite ROTM winner for the year of 2021 HERE!
1 - 7 of 7 Posts

·
Premium Member
Joined
·
123 Posts
Discussion Starter · #1 ·
I installed a ppe lift pump and wired it to a switch through a relay. When i flip the switch on the injectors get louder and it wants to idle rough. The fuel presure gauge reads 1-2psi without pump and 12.5psi with pump on? I bled the system of any air and have driven 10 miles and the condition continues?

ALso when I did the pump I installed ported rail fitings and a race valve to restrict the return? Can I not use the race valve with the lift pump?

Thanks for any help,
 

·
Premium Member
Joined
·
123 Posts
Discussion Starter · #3 ·
Thanks for the info I will adjust it tonight and see what happens?
 

·
Premium Member
Joined
·
123 Posts
Discussion Starter · #5 ·
The regulator never had an issue before? I guess the new PSI is a bit too much for it.
 

·
Hi, I'm Earth. Have we met?
Joined
·
3,162 Posts
Yeah to much psi will flip the FICM out. My truck will only take 8 psi and my wifes will take 14, so every truck is a bit different, dont go to high though or you can cause serious damage to the FICM!
 

·
Premium Member
Joined
·
123 Posts
Discussion Starter · #7 ·
I bumped down to 10 and it seemed to behave Ok. I have not had a chance to run it and verify that the issue is gone. I guess this weekend at the track i will just turn it down until injectors are smooth and not eradic?
 
1 - 7 of 7 Posts
Top