Chevy and GMC Duramax Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I've got an 04' silverado with a vin 1 lb7 and once every couple months it will crank but not fire no matter how long you crank. I replaced the primer pump, fuel lines and fuel filter. It changed nothing. I can prime it up tight with no air and as soon as I crank it I lose the prime. I can prime it repeatedly and same thing over and over again. I go in the house for 15 minutes, come out and it fires right up and runs great for a few months before the same thing all over again. It's starting to get pretty old. Any thoughts?
 

·
Registered
Joined
·
31 Posts
My truck periodically does this as well. I am getting air somewhere in the filter head or from the filter it's self. I have rebuilt the primer pump, changed the hoses and filter before but never changed the whole filter head so that's next on my list.

I put a clear line between the ficm and filter, then another from there to the cp3 and only see the bubbles after the filter. You might try the same and see if you are pulling air from the ficm.

I would expect if you have a lift pump you will solve your issue or be able to find the fuel leak once you have positive pressure instead of negative also.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
That was going to be my next move, installing a lift pump. I like the idea of the clear hoses. I think I'll give that a shot too. Thanks.
 

·
Registered
Joined
·
31 Posts
That was going to be my next move, installing a lift pump. I like the idea of the clear hoses. I think I'll give that a shot too. Thanks.
I used some cheap junk that I couldn’t get all the kinks out of but this video shows what I was looking at.
 
1 - 4 of 4 Posts
Top