Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Since this is my first diesel truck this might be a normal condition when it's new but for some reason my LBZ doesn't seem to have much pep to it. Seems like I really have to give it some throttle to get it moving. Truck only has 300 miles on it so far. It seems to run nice and smooth but doesn't get up to speed very fast.

Should I be concerned?

SP
 

·
Oh...... Squirrel!
Joined
·
24,083 Posts

·
Administrator
Joined
·
8,815 Posts
I'm with tow master, even in stock form the truck should sit you back pretty decent. I know that with my programmers set to about the same power of the LBZ, I always have a smile on my face.....and I have 285s on my truck.
 

·
Received a Hummer
Joined
·
9,627 Posts
I just bought a brand new 07 Classic LBZ....and when we went on our test drive...I had the tires chirping when gunning it to get on the Highway. Only thing I noticed that was weird was the shifting patterns...but noone told me if you have an Ally...it has to (learn) how to shift.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
The truck will move out with no problem if I get into the throttle but maybe I'm just use to my Silvy 1500 I sold to purchase this vehicle. The wife and I are going out of town this weekend I'll how the dieselnator performs.

Thanks,

SP
 

·
Diesel Addict
Joined
·
7,754 Posts
i went from a 00 1500 silverado w/t 5.3L to the LBZ and the LBZ will put a whoopin to the 5.3L even with a 14ft car hauler behind the LBZ(don't ask how i know about that LOL i love racing)both in stock tunes..some thing is wrong take it back to the dealer and have them check it out..
 

·
Registered
Joined
·
7 Posts
????? but my 07 LBZ with 8432 mi. on it has been in the shop for two weeks with some kind of turbo problem..... just my "luck" pick one that's a crapper! But the first 8300 mi were alot of fun!!! The Bridgstones didn't like it very well though!
 

·
Registered
Joined
·
699 Posts
i've noticed alot of throttle feel difference, me wifes 5.3 tahoe will haul ass with very little throttle movement but lacks in mid to hard throttle. my lbz 3500 lacks in light throttle but screams mid to full. what takes my pedal movin an 1/1/2" hers does in 1/4". that LT3 autoride Tahoe ain't got a chance in hell of burnin rubber or pullin like my 3500 WT LBZ can.
 

·
Registered
Joined
·
65 Posts
You could be experiencing from take off what is called turbo lag. It's because there is lack of boost at low rpms. I had a 6.0 Powerstroke do the same thing.
 

·
Registered
Joined
·
72 Posts
I noticed the same thing when I got my LBZ, it is normal. It's a feel difference, not that you're lacking in power, right? After I added my Superchips, it was night and day. Throttle response right away. Either get a programmer or get used to it, there isn't anything wrong IMHO.
 

·
Registered
Joined
·
680 Posts
Running a diablo on 85, str8 pipe, cai mod, I notice a little lag aswell on my lbz. But mid to high freakin blow the sh*t out of everyone. But do notice from time to time when I do hit the throttle hard from dead stop tires break loose.
 
1 - 11 of 11 Posts
Top