Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Premium Member
Joined
·
615 Posts
Discussion Starter · #1 ·
I changed my fuel filter out with a Racor about a week and a half ago. I do not have steering wheel controls so when I finished I turned my key to ACC On position, waited 5 seconds, pushed both pedals to the floor for 10 seconds, then let off and turned the car off then on again.

I didn't see the change fuel filter minder after that until just yesterday. Coincidentally it's rain here, is there any chance this is increasing my water content in the WIF sensor and triggering it to alert me?

Why else would the alert be coming back after such short time, having been gone entirely after the last change.
 

·
Premium Member
Joined
·
615 Posts
Discussion Starter · #2 ·
No thoughts? I don't want to ignore the fuel system if somehow it actually is in need of a change again, but I also would want to address what ever caused it to go bad so quickly.

If it's just simply that I did the wrong thing to reset it then Can anyone direct me to the right way?
 

·
Premium Member
Joined
·
26,484 Posts
WIF sensor it's not. Measures restrictions.
Try and reset again, see if it comes back. I've had that happen once, made me second guess whether I'd reset properly.
 

·
Premium Member
Joined
·
615 Posts
Discussion Starter · #5 ·
WIF sensor it's not. Measures restrictions.
Try and reset again, see if it comes back. I've had that happen once, made me second guess whether I'd reset properly.
Tried resetting again today...

1.Turn key to last setting before actually cranking it
2.Wait 5 seconds
3.Push both gas and brake pedal fully to floor and hold for 10 seconds (pushed hard to make sure I was going all the way)
4.Letup after 11-12 seconds just to be sure (no confirmation of any kind that what I did worked)
5.Turned key off
6.Turned key back on - no message

Later tonight, got the message again. If the replacement reminder goes off time only, then I'm not resetting it properly obviously. If it somehow is measuring the effectiveness of the filter, which is what I'm afraid of, then somethings up with the truck.
 
1 - 5 of 5 Posts
Top