Chevy and GMC Duramax Diesel Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
636 Posts
Discussion Starter #1
So I had a buddy of mine load a single tune until I get my switch in but I have a 100hp tune in. Everything went fine, until earlier. I went for a drive and check engine light went on. So I came home. When I shut it off I heard a loud noise from the engine compartment that sounded like an electric motor running. It got louder and louder then stopped. I had him reflash it and he played with the turbo vanes. He thought it may have been the vanes shutting. I ran the truck around the streets for a little no engine light. Shut it off and no noise.
Truck sat for about 3 hrs, I took it and when I brought it back the noise started again. It's really bothering me.

Does anyone know what this may be? It almost sounds like a electric fuel pump. Really weird and starting make me regret this.

Please help
 

·
Registered
Joined
·
2,097 Posts
sounds like the fprv maybe going bad ?
 

·
Im Superrrrr!
Joined
·
14,517 Posts
Where did the tune come from?

What codes are present?

You saying you regret getting EFI, is kinda ignorant IMO. It is in many circles the best tuning software out there....

I would moreso say its user error on your part for not thinking ahead.

You did just throw a 100hp tune on a stock trans truck.

but I'd say its your vanes opening and closing on the turbo and/or EGR:poke[1]:
 

·
Registered
Joined
·
636 Posts
Discussion Starter #5
I'm not sure what the code was I think he said the maf sensor because of the added fuel.
I only said I regret it because this is my daily driver, I don't drag race it. Just like the extra power.
The noise is just creepy. I'll have to go out there later and record it.
 

·
Registered
Joined
·
366 Posts
So have him flash the stock tune back and see if it still happens. Is it possible that your buddy flashed his tune for his truck into it? That can mess things up I hear. My guess is that something he changed in the tune is causing the problem.
 

·
Registered
Joined
·
636 Posts
Discussion Starter #7
The tunes were some he got from a friend with the same truck. 06 lbz.

It's definitely coming from the turbo like the vanes are closing after shut down. It's quiet when the truck is cold but once it gets up to temp it gets loud.
 

·
I'm That Guy...
Joined
·
16,689 Posts
You can't just load tunes from another truck, just because they are both 06 LBZ doesn't mean they use the same calibration.

Sounds like your issue is not buying tunes from a reputable tuner. Saving a few hundred $ isn't worth the $3k-10k a bad tune might cost you.

Where did he get that tune for his 06 LBZ?
 

·
Registered
Joined
·
636 Posts
Discussion Starter #10
I'm not sure about any of it. I'm new to this. But he's coming over today and bringing the guy that he got the tunes from. Were gonna hook it back up and play with it some more.
 

·
Registered
Joined
·
462 Posts
dude flash your stock tune back in then leave it alone until you get a set of tunes from a pro like idahorob
 

·
Registered
Joined
·
636 Posts
Discussion Starter #12
All fixed we reflashed and re calibrated the tune and it's good to go.
 
1 - 12 of 12 Posts
Top