Chevy and GMC Duramax Diesel Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
I really need input here guys.....let me catch you up.
18 GMC 2500 L5P. 65K miles CEL came on about 2000 miles or so ago. Truck was running fine and was using DEF normally but CEL keeps returning on a P026D. Changed MAF sensor and inlet temp sensor, CEL still returns. Took truck to dealer for reflash recall and P026D was gone after but returned next day. Dealer didn't mention code.

Took to diesel shop today, he hooks up. Everything is looking ok except CEL is on ( P026D ) Wrench doesn't see any issues , checks injectors, all is good. Wrench orders a manual regen and CEL goes out on its own. Tells me to drive truck and report back. SO it appears truck is NOT regenerating on its own but it is using DEF. Wrench says soot level shows 32% but says he doesn't believe that. Wrench has no clue wassup.

Any ideas??
 

·
Registered
Joined
·
6,025 Posts
Why not take it to a dealer?
Should still be covered.

DEF is used whenever it's running. It's not a regen only thing.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #3
Thanks man . Emision warranty is out at 50k on these. Not paying $180 / hr to have someone scratch head.
 

·
Registered
Joined
·
243 Posts
Have you noticed any reduced power issues? Light going off at dealer then back on means that the system was reset - it determined a fault somewhere after everything got back moving again.

Curious if your DPF filter is messed up and not burning out properly
 

·
Registered
Joined
·
42 Posts
Discussion Starter #5
Back again. so far no CEL with the loosened fuel cap but code persists and 2 more from the brake controller. MAF numbers are red on scanner. Shows about 18.xx at idle. Also bought the new CRP 429C and plugged her in. Still reading on how to force a regen if needed.

If you guys could point to the step and save me a few......
 

·
Registered
Joined
·
6,025 Posts
Thanks man . Emision warranty is out at 50k on these. Not paying $180 / hr to have someone scratch head.
Like most businesses, there are good ones and bad ones.
 

·
Registered
Joined
·
95 Posts
I had a similar case yesterday. I've got 61k miles on my truck. My low DEF signal had come on the last time that I had driven it, before I parked it at home.
So yesterday, I tried to remote start my vehicle, it turned over and fired, then shut off (I wonder if it is because the DEF was low? But 29/30% sure doesn't seem low enoguh for it not to start?). When I got in, I started it up with the key, and the CEL was on. I read the same code as you, P026D. I cleared the code with my I-dash, and added DEF. It didn't happen the rest of yesterday.
Sorry, I don't have any explanation for either of our cases, hopefully someone with more experience does.
 

·
Registered
Joined
·
243 Posts
As i understand it, Autostart will not function if the CEL is illuminated, regardless of the code.
 
  • Like
Reactions: Ron505

·
Registered
Joined
·
163 Posts
Correct - no remote start when CEL is on
 
  • Like
Reactions: Ron505

·
Registered
Joined
·
95 Posts
Good info. The CEL wasn't on when the truck was parked. It must have came on when I tried to remote start it.
 

·
Registered
Joined
·
6,025 Posts
A CEL does prevent a remote start, but low def shouldn't cause a CEL.
(maybe if it's down to zero/empty and has given the 500 mile to 65 mph speed restriction message?)

also won't remote start of hood is open

And I know for sure that I've remote started mine often at way less than 30% remaining.


The vehicle cannot be remote started if:
. The key is in the ignition.
. The hood is not closed.
. There is an emission control system malfunction and the malfunction indicator lamp is on.
. Fuel level is too low.

The engine will turn off during a remote vehicle start if:
. The coolant temperature gets too high.
. The oil pressure gets low.



Oh, and you only get 2 remote starts, or 1 start and an extension before it is necessary to do a key cycle.
 
  • Like
Reactions: Ron505
1 - 11 of 11 Posts
Top