Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello to all, 2002 lb7, 130000 miles 500 miles on new injectors.
Yes I have searched the forum many times looking for the best answer to my new problem. I had new Bosch injectors installed into my truck all of them, new glow plugs also. I now have plumes of white smoke at start up for atleast 15 minutes, and as I start driving. Looks as though it is fuel to me. I have added a link to several videos below. l Any advice would be greatly appreciated. Tired of getting charged $200 for diagnostics every time I take it somewhere.

No loss in power
turbo spools the same as before injectors were replaced.
not over heating

Mods on truck
banks big head waste gate
k&n CAI ( I know not the best)
bank exhaust

possible problems from lots of reading

I got a bad injector
Injector cup came loose during install
pcv valve?
possible FPR problem
bad rings
hole in piston.

Link to pictures: https://www.dropbox.com/sh/27u6q4teqgzw3r7/AAA4cKR3J9M2lJUZUY__QPEia?dl=0

I just got sent to Germnay for a few years and truck is in Washington, if anyone knows of someone local there that could help.
Thanks Paul
 

·
Registered
Joined
·
448 Posts
My guess is a injector hanging wide open
 

·
Registered
Joined
·
164 Posts
Since All Glow Plugs were changed, the absolute first thing I would do is check
the current draw of (or Resistance of) each Glow Plug. Second, I'd verify each Glow
Plug's connection with the Buss (or Jumper Wires) to the Controller for each bank.
A loose or HIGH RESISTANCE connection can cause you lots of problems. That should
be an easy test, but is time consuming, and they are hard to get to.


Larry
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 · (Edited)
Hey thanks for the replys, here are the balance rates taken by dash command. #8 is off more then the rest and is the usual problem cylinder, but isn't crazy bad.
-.7
.2
-.9
-2.1
0.0
.7
-1.0
3.7
 

·
Registered
Joined
·
124 Posts
It's injector 8, or injector with the 3.7 reading. Try cleaning the injectors forst before you spend the time tearing apart the passenger side of your engine apart.
 
1 - 5 of 5 Posts
Top