Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Vote for the Site Favourite ROTM winner for the year of 2021 HERE!
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I am trying to troubleshoot a miss in my 2003 GMC Sierra 2500HD LB7 ZF6 NP261. It has an intermittent problem at lower and higher constant speeds where it will hesitate and you can hear the clutch unload/reload. The motor was completely rebuilt 20,000KM ago. The injectors are 50,000km old and from the previous setup and are stock replacement. It has a new cp3 and a fass 95 lift pump with a filter delete bowl. Since I had this issue I replaced my fuel filters. It doesn't throw any codes, the balance rates are within 2% at idle. It has a South Bend dual disc clutch with about 60K on it. I took it to a shop who found I was losing my MAF intermittently, my plastic clip on the sensor was NFG so I pinned in a new connector and tried a couple different sensors I had access to, one off of my parts LLY and one off of another running LLY on the farm; all with the same running characteristics(and same part numbers).The MAF signal is now a non-issue. I did some data logging with my AutoCal and seemed to yield fairly consistent readings. My rail pressure is steady. While driving down the road it will seem to unload temporarily while at cruising speeds but you can punch the throttle and it isn't lacking power. This has been very frustrating and I am not wanting to let a shop blame it on injectors without due process. Has anyone had similar experiences? I am also willing to share my data logs with anyone who is able to see something I cannot.
 

·
Registered
Joined
·
4,656 Posts
Exactly what is your MAF reading in gm/sec at idle?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
1 - 3 of 3 Posts
Top