Chevy and GMC Duramax Diesel Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a 2003 gmc 2500HD LB7 4wd with 290k on it. Recently I've noticed it "jerk" for a split second only while cruising the interstate. The transmission fluid looks great and smells great. I took down the pan to change the inside filter along with the spin on filter. Everything looked good on transmission side. I've read that a transfer case might cause my problem. So I checked the transfer case fluid and it was black, but full. Went ahead and changed it. So my question is... Is it possible that it is in fact the transfer case? If so, what do I look for as culprits when I take it apart? Thanks!
 

· Registered
Joined
·
1,229 Posts
Honestly typically a jerk is power related in my experience. Is it sporadic? often? any particular gear? I assume 4th gear locked up converter, you feel a slight jerk? I'd monitor the engine for any blips in RPM or changes overall.
 

· Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Honestly typically a jerk is power related in my experience. Is it sporadic? often? any particular gear? I assume 4th gear locked up converter, you feel a slight jerk? I'd monitor the engine for any blips in RPM or changes overall.
It started out as maybe once in a 30mile trip. Only happened going 70mph-80mph. As weeks went by, the jerk is the same, but more frequent. I forgot to mention previously, but transmission went into limp mode once because of the jerking. Got code P0705. I thought originally it was also power. RPM didn't move though. The jerk feels like when someone is about to tow you and goes to tighten the strap but goes a little too fast.
 

· Registered
Joined
·
4 Posts
I’m really thinking I have the same issue. Any luck? From what I read that range fork gets sloppy from wear and that actually causes ur speed sensor on the back of ur transfer case to not match the transmission speed sensor and that’s why it throw the pickup in limp
Just wanted to post on here that I went ahead and took out and tore apart the transfer case. Bunch of metal shavings in there. Mode fork looked good, however, the range fork was ate up. Going to do a rebuild kit and update if this fixes the issue.
 
1 - 5 of 5 Posts
Top