Chevy and GMC Duramax Diesel Forum banner

1 - 5 of 5 Posts

·
Smoke. It's what's cookin
Joined
·
2,934 Posts
Discussion Starter #1
Ok here's the story.
January I swapped motors in my LBZ. Left off the dual pumps. It ran good no problems. BUt one time at home the truck started then died immediately. Started again adn died. Started third time and held foot on throttle and stayed running. Ran around and it was fine. Went to start a couple days later and batteries were weak. Replaced batteries and everything was fine. Batteries were replaced in Feb. 2 weeks ago I had it detuned for a more streetable truck. Well On sunday I was driving around with wife and daughter and stopped at a stop sign and truck shut down and dash said not charging. Started right back up and amps were around 14. Pulled into Pep boys to check it out and see if they might have an alternator. No luck in town. Figured I could make the errands and home. well Stopped at another light and it died again. Started right back up.

Put new alternator on yesterday and started fine and rans 2 minutes and died. Started right back up and ran a couple more minutes and died. On the second time when it died it knocked a little bit. Sarted it up today and it ran for about 2 minutes and made a couple knocks but stayed running. Drove around town for some errands and back to the shop and I stopped and was letting the pyro cool and then it died.

Everytime it has died, No codes. I've checked the grounds, disconnected the batteries and reconnected. Checked grounds on block and any I can find. I'm Puzzeled. Any ideas on diagnosing?

thanks.

Ryan
 

·
Smoke. It's what's cookin
Joined
·
2,934 Posts
Discussion Starter #3
No we didn't put any dialectric grease in there but it's like someone just shuts the power off. Don't know why it would just now do it when it's been back on the road since Jan. Not on a regular basis but I would drive it. Not sure if when it got retuned/detuned that it is something in the tune? Also I delted the EGR so not sure if something with that is causin an issue. But it's turned off.
 

·
Im Superrrrr!
Joined
·
14,517 Posts
sounds like a fuel issue...I know with the mods you have, you have prob checked your fuel filter.

Maybe try and reload another tune and see if thats the issue as well.
 

·
Smoke. It's what's cookin
Joined
·
2,934 Posts
Discussion Starter #5
I think it might be tuning issue. Talked with the shop it was tuned at and they have another truck, lb7 that is doing the same thing and the only common denominator is the laptop used and has been acting up.
 
1 - 5 of 5 Posts
Top