Chevy and GMC Duramax Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
335 Posts
Discussion Starter #1
Two days in a row ive started my truck no problems. But for the first little bit that i drive it if i stop it wont go when i hit the gas, like its in neutral then it jumps into gear. this goes away fairly soon however. then the check engin light comes on and it goes into limp mode. The Oil pressure is also reading higher than normal. The first day i just asumed my it was due to the 250,000 miles on the oil gauge ( ive had problems with it before) and transmision. though before this the gas guage started to not work until ive driven for a little bit. Ive got a bunch of trouble codes about loss of communication between stuff and the other half are for trans fluid pressor sensors . the firs day i drove for awhile and it started to drive normal exept for a higher than normal oil pressure. The second day i cleared all the trouble codes. Im wondering if my computer is going bad. I have some elecrical stuff that doesnt work or randomly stop working.

Any ideas about if the computer going could cause this. or anything else.? Id be in your debt.
 

·
Premium Member
Joined
·
17,806 Posts
Instead of telling us you have trouble codes-- and assume the problem is something else---Why don't you list the codes-- that does help diagnose problems.

If you want guesses-- replace the ignition switch.

They are easy to replace-- and do go bad.
 

·
Registered
Joined
·
335 Posts
Discussion Starter #3
P0101
P0700
P1621
P0841
U1024
P0846
P0848
P0872
P0875
U1016
U1152
U1026
u1026
U1064
 

·
Registered
Joined
·
335 Posts
Discussion Starter #4
Fixed it. My programmer was freaking out. Guess thats what i get for not buying a nice one.
 

·
Premium Member
Joined
·
17,806 Posts
Sometimes the pins will bend and not make good contact on the programmer connector--Glad you have it fixed.
 
1 - 5 of 5 Posts
Top