Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Vote for the Site Favourite ROTM winner for the year of 2021 HERE!
1 - 20 of 21 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
Last drove my truck a few weeks ago and didn't have any problems. Hopped in it yesterday and found that the Service Engine Soon light is on now. It also seemed like it reved up higher than what it needed to in order to move what little it did. Does the transmission start in overdrive when the truck is in limp mode to help protect something. Also I had no reverse, it would not move at all in reverse. Just to busy right now to have it looked at, or even look at it myself. If anyone has any pointers please let me know or where to start at. Truck is a 01, which is bone stock.
 

·
Registered
Joined
·
1,486 Posts
Probably stuck in third.... Sounds like a nsbu switch, Do a search on it and you will find it's verry comon on the earlier Dmaxes...
 

·
Registered
Joined
·
1,486 Posts
If I recall pretty cheap part and easy to do if that helps...
 

·
Registered
Joined
·
118 Posts
i have no idea what limp mode is..cause im like a rock! lol

but 1 time i took off fast then let off the gas right before the truck was gonna upshift and it did some hard narly shift then i stoped at the next light. then it felt like the tranny was sliping, it got about 15 degrees hotter by the time i parked. went to leave a hour later and it was fine.. idk weird
 

·
That One Guy
Joined
·
7,421 Posts
Do you have all the dash lights for D,N,R,3,2,1? If so then its not a NSBU switch it would be limp mode. When was the last time you changed your fuel filter and trans spin on filter?

Yes sicknick that would have been limp mode and it clears itself after the truck is shut off for a little bit.
 

·
Registered
Joined
·
1,486 Posts
i have no idea what limp mode is..cause im like a rock! lol

but 1 time i took off fast then let off the gas right before the truck was gonna upshift and it did some hard narly shift then i stoped at the next light. then it felt like the tranny was sliping, it got about 15 degrees hotter by the time i parked. went to leave a hour later and it was fine.. idk weird
Probably limpoed yours for sure and it feeling like it slips is cause it was stuck in third gear... My guess is its fine now or feels normal again???
 

·
Registered
Joined
·
1,486 Posts
Do you have all the dash lights for D,N,R,3,2,1? If so then its not a NSBU switch it would be limp mode. When was the last time you changed your fuel filter and trans spin on filter?

Yes sicknick that would have been limp mode and it clears itself after the truck is shut off for a little bit.
Thought you have reverse in limp mode????
 

·
That One Guy
Joined
·
7,421 Posts
Nope no reverse in limp mode she locks in 3rd.
 

·
Registered
Joined
·
1,486 Posts

·
Registered
Joined
·
118 Posts
yeah never happend since and feels good. think my foot got lighter after that one.for a little
 

·
Registered
Joined
·
1,486 Posts

·
That One Guy
Joined
·
7,421 Posts
Yeah never know what limp mode was until I did it a time or two after I got my truck then decided I better learn a little more about these trucks before I ruin it
 

·
Registered
Joined
·
7 Posts
I had this issue twice now and I replaced the P&P switch on the side of transmission. It's a pretty easy fix but the part is pretty pricey. Hope this helps.
 

·
Registered
Joined
·
35 Posts
Last drove my truck a few weeks ago and didn't have any problems. Hopped in it yesterday and found that the Service Engine Soon light is on now. It also seemed like it reved up higher than what it needed to in order to move what little it did. Does the transmission start in overdrive when the truck is in limp mode to help protect something. Also I had no reverse, it would not move at all in reverse. Just to busy right now to have it looked at, or even look at it myself. If anyone has any pointers please let me know or where to start at. Truck is a 01, which is bone stock.
Its most likely the neutral saftey switch..mine did the same thing...when it was in gear did the dear light flash?
 

·
Registered
Joined
·
72 Posts
my truck did the same thing twice on me last winter. The reverse light would blink and it wouldnt move until I shut it off and started it again, it was the neutral saftey switch.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #19 ·
I changed the fuel filter with a WIX about 3,000 miles ago, and the tranny filter at the same time. Tried er again this morning. The first time it went into all gears fine including reverse, none of the gear selections were blinking or flashing. However the service engine soon light was still on. So I shut her off and did the same thing with the same results, again it goes into all gears again with the service engine light still on. So I then tried starting it in nuetral, started fine and after it started it the service engine soon light went off. What are you guys thinking, are you still thinking the pnp nuetral switch?
 

·
Registered
Joined
·
72 Posts
I changed the fuel filter with a WIX about 3,000 miles ago, and the tranny filter at the same time. Tried er again this morning. The first time it went into all gears fine including reverse, none of the gear selections were blinking or flashing. However the service engine soon light was still on. So I shut her off and did the same thing with the same results, again it goes into all gears again with the service engine light still on. So I then tried starting it in nuetral, started fine and after it started it the service engine soon light went off. What are you guys thinking, are you still thinking the pnp nuetral switch?
After I got mine to go into reverse the check engine light stayed on for a day or so.
 
1 - 20 of 21 Posts
Top