Chevy and GMC Duramax Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey guys new to the forum and kind of new to duramax. I have a 2005 LLY duramax. The engine is brand new 1 yr ago and it probably have 200 miles on until about 2-3 months ago. I’m in Alabama and on my way to visit family in Texas. The truck has ran like a top all except the tie rods, but I had a quarter tank of fuel and I filled up at a shell station and made it about 2 miles where I got to running speed at 75mph and all of a sudden the cel comes on and it’s running very rough with almost no power. Got a couple miles down the road to a chevron and pulled the fuel filter. I’ve been in the diesel industry for awhile now working on Peterbilts. I’m no expert but I’ve compared my fuel to the chevron diesel and it smells different. So I come back to the shell and I compare the diesel fuel to the gasoline and I can swear I smell gasoline in the diesel. I pulled diesel from the truck stop side and it does not smell like the diesel in my fuel filter.
the fuel filter is new about 2-3 months ago, and I have gauges that I watch regularly and nothing was weird when the cel came on and she went into limp mode. Engine oil is fresh,I have oil pressure, turbo pressure and everything seems to check out fine except for it running like shit.
egr and egr wire harness has been deleted.
 

·
Premium Member
Joined
·
8,669 Posts
What’s the question?

Pull your codes and see what that tells you. Sounds like you got bad fuel.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I filled up fuel filter with good diesel and she is back to normal until it starts sucking gasoline. So I’m gonna go with that. I’ll see if I can find a new fuel filter just to make sure
 
1 - 3 of 3 Posts
Top