Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 15 of 15 Posts

·
Registered
Joined
·
863 Posts
Discussion Starter · #1 · (Edited)
Hey guys Ive been having some injector problems in the last couple of months. Its not a Harrness or connector problem either. Back in dec i got #6 repalced with a new bosch reman because it had a +5.5 rate. Now im having a bad knock under easy acceleration. WOT no noise, only knocks when engine is at operating temp. I know its coming from the drivers side. I can put diesel kleen in and the knock will go away but as soon as i fill up without using additive the knock comes back and it sounds terrible. Heres a look at my rates at operation temp. Im Guessing its either #6 or #8.. Any ideas guys? would a leaky inj cause a knock or a sticking closed inj cause a knock? Im guessing my #6 inj i just replaced took a shit after only 3k.
 

·
Registered
Joined
·
619 Posts
Are those in park or drive? Truck at operating temperature? Both #6 and #8 are within spec for either park or drive as long as the truck is warm...
 

·
Registered
Joined
·
863 Posts
Discussion Starter · #3 ·
Its in park and yes as I stated above I took the pic at op temp..
 

·
Registered
Joined
·
399 Posts
Rates look good. I believe gm specs a bad one at +/- 6? Correct me if iam wrong. Some of my injectors are +3. Runs fine.
 

·
Registered
Joined
·
5,777 Posts
You need to use a V2 or Tech 2 to turn off the injectors one by one until you find the offending injector and replace it.
Obviously double check the injector connections/wiring before hand as well.
 

·
Registered
Joined
·
863 Posts
Discussion Starter · #7 ·
Doesnt the DVT controlls used to shut off inj in an LLY not always turning off the inj your telling it to??
 

·
Registered
Joined
·
5,777 Posts
Doesnt the DVT controlls used to shut off inj in an LLY not always turning off the inj your telling it to??

I believe the folks at EFI fixed that issue now (ie prior hardware/software rev).
 

·
Registered
Joined
·
863 Posts
Discussion Starter · #9 ·
I believe the folks at EFI fixed that issue now (ie prior hardware/software rev).
Well if thats the case ill try the DVT controls here in a bit and report back.
 

·
Registered
Joined
·
5,777 Posts

·
Registered
Joined
·
112 Posts
I have the same exact problem as the OP.
 

·
Registered
Joined
·
5,777 Posts
I have the same exact problem as the OP.

Then you'll need a V2 or Tech 2 in order to figure out which one is causing the issue.

This is assuming any FICM wiring issues (injector connections / alt bracket) have been addressed already.
 

·
Registered
Joined
·
863 Posts
Discussion Starter · #13 ·
Well its injector #6 thats causing my knock I finally got a chance to shut off each inj last night. Its only 3-4 months old so i will see if i can use my warranty on it.
 

·
Registered
Joined
·
399 Posts
You need to use a V2 or Tech 2 to turn off the injectors one by one until you find the offending injector and replace it.
Obviously double check the injector connections/wiring before hand as well.
snapon solus too modis probably will too.
 

·
Registered
Joined
·
5,777 Posts
Well its injector #6 thats causing my knock I finally got a chance to shut off each inj last night. Its only 3-4 months old so i will see if i can use my warranty on it.

Not fun but at least you found your issue.
 
1 - 15 of 15 Posts
Top