Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 20 of 47 Posts

·
Registered
Joined
·
915 Posts
Discussion Starter · #1 ·
Im on my last nerve with this truck. im sure everyone saw my thread a few weeks ago where i fried my ecm while flashing it. Well i got a new ecm took it to the dealership where my friend works and he took a tech2 and flashed it. Put it in everything worked fine. i drove around on the stock tune for a few days but its just wayyy to slow. So i brought out the v2 hooked it up and went to flash my ecm but its still doing the same crap it did last time before i fried it! :mad: cannot communicate with ecm, cannot det OS. WTF! i hate this truck only if i had waited one more year and got a lbz. i pulled all the right fuses and tried again but after 4 epic failures i decided to quit while i was still ahead of the game. any ideas why this pos wont flash??
 

·
Registered
Joined
·
485 Posts
sorry to say it has nothing to do with it being an LLY..that being said when you say you pulled the "right fuses" what do you mean?
 

·
Registered
Joined
·
915 Posts
Discussion Starter · #3 ·
Radio and info fuses. The lly ecm's are known for being a pain in the butt to flash.
 

·
Registered
Joined
·
485 Posts
oh didnt know, first time Im hearing of someone frying there ecm twice, thats why I have someone else do it for me lol..I was going to mentioon the radio fuses but you havethat covered, hopefully someone else will chime in
 

·
Registered
Joined
·
915 Posts
Discussion Starter · #5 ·
i wish i had somebody to do it for me lol then they would have to pay for my ecm if they fried it :rof there is just somthing about the lly. im thinking about sending my ecm and my tunes to a vendor and let them flash it. i just cant drive around on the stock tune anymore. i got outran by a cummins yesterday and that put the iceing on the cake i cant do it anymore.
 

·
yep yep...
Joined
·
7,169 Posts
oh you know you love it, take a boot to it and show it just how much you care. i did mine. are you pulling the 2- 10 amp fuses and the 2- 15 amps?
 

·
Registered
Joined
·
1,920 Posts
what....there is 2 other ones?...lol
 

·
Registered
Joined
·
915 Posts
Discussion Starter · #8 ·
idk i just pull the ones that say info and radio lol. im bout to have a nervous breakdown and start ripping chit out! i havent fried it yet so like i said im gonna leave it to the pros to do it lol. Im gonna take a trip to georgia diesel and let them tune it and take some notes. Its not that i dont know that im doing ive flashed this thing 1,000 times but for the 1,000 times i got it to flash it took 2,000 tries lol.
 

·
yep yep...
Joined
·
7,169 Posts
it depends on the tuner but i pull all 4 of them reguardless just to be sure,never had any trouble and ive ran several different ones. ill go look and tell which ones for sure.
 

·
Registered
Joined
·
915 Posts
Discussion Starter · #10 ·
it depends on the tuner but i pull all 4 of them reguardless just to be sure,never had any trouble and ive ran several different ones. ill go look and tell which ones for sure.
thanks man :drink hopefully this will fix my problem
 

·
Registered
Joined
·
915 Posts
Discussion Starter · #11 ·
i just found a thread on diesel place where this guy with a lly had the same prob and he pulled 4 fuses also. there was somthing about having the doors closed when you flash the ecm and not opening them while your flashing it. hmm new one on me but its worth a try
 

·
yep yep...
Joined
·
7,169 Posts
they are, TBC BATT-10 amp, TBC IGN1-10 amp, RADIO- 15 amp, INFO -15 amp. thats the ones i've pulled for ppe, superchips, bullydog,and quad, and i've re-tuned mine hundreds of times.
 

·
yep yep...
Joined
·
7,169 Posts
hmm i always turn my heater off but ive never closed my doors unless it was rainin, but its worth a try.
 

·
Registered
Joined
·
915 Posts
Discussion Starter · #14 ·
ill pull the fuses and see what goes thanks for the help man. if this soesnt work im gonna give chuck norris a ring and let him come over and round house kick the chit out my ecm.
 

·
Registered
Joined
·
915 Posts
Discussion Starter · #15 ·
hmm i always turn my heater off but ive never closed my doors unless it was rainin, but its worth a try.
ive never heard of it either :confused: the thing that pisses me off is that most ppl with efi live dont have to pull fuses or anything they just flash and go
 

·
Registered
Joined
·
5,569 Posts
ive never heard of it either :confused: the thing that pisses me off is that most ppl with efi live dont have to pull fuses or anything they just flash and go
Most likely the reason you are having to pull all those fuses, is cause you door is open "power being drawn while you are flashing". I have never pulled a fuse, but I do not open my doors either. What I do since mine takes so long to flash is roll the window down, so I can set my laptop on the hood "be care full not to drop it". Then make sure the radio, and headlights are off. So far never once had one problem.
 

·
Registered
Joined
·
915 Posts
Discussion Starter · #17 ·
Most likely the reason you are having to pull all those fuses, is cause you door is open "power being drawn while you are flashing". I have never pulled a fuse, but I do not open my doors either. What I do since mine takes so long to flash is roll the window down, so I can set my laptop on the hood "be care full not to drop it". Then make sure the radio, and headlights are off. So far never once had one problem.
good idea. so maybe the door being open was my prob after all
 

·
Registered
Joined
·
5,569 Posts
good idea. so maybe the door being open was my prob after all
I will tell you that one time I was inside "in the middle of programming" and my wife opened the door. It froze up, and said ECM in unknown state, and some number after the word Seed. I had to shut down EFI, and tried to start the truck to no avail. I thought I was screwed, but tried a full system reflash and everything turned out OK.

I know where you are coming from when that warning comes up, as ECM's are not cheap.:drink
 

·
Registered
Joined
·
5,569 Posts
Also I can not tun it with the Use High Speed checked. I have to unchecked that and select TRY ALT Keys. I have asked why numerous time's, but no one has ever answered.:confused:
 

·
Registered
Joined
·
915 Posts
Discussion Starter · #20 ·
I will tell you that one time I was inside "in the middle of programming" and my wife opened the door. It froze up, and said ECM in unknown state, and some number after the word Seed. I had to shut down EFI, and tried to start the truck to no avail. I thought I was screwed, but tried a full system reflash and everything turned out OK.

I know where you are coming from when that warning comes up, as ECM's are not cheap.:drink
so it all makes sense now. the same day i fried my ecm my gf opended the door while i was flashing it. i tried a full flash with the v2 and tech2 but it was already fried. thanks for the good info. and yes ecm's are not cheap by no means ive fried two so far lol. lesson learned dont open door while flashing. :drink
 
1 - 20 of 47 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top