Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
2004.5 lly bone stock

Fire up truck yesterday and get CEL
Scan and get P0601, did some research here and elsewhere online. Checked wiring at alternator bracket, some wear but nothing that looked like it would cause problem. Kept clearing the code, restarting, and it would reappear after a couple mins while idling. I read somewhere else to try disconnecting both batteries and let it sit for a couple hrs. It sounded like a real long shot but I thought nothing to lose right? I reconnected both batteries and now I have a no crank situation. I have lots of battery power, dash lights up but nothing with key to start position. I was able to troubleshoot to no trigger signal at starter Relay in fuse box. I can jump relay and get truck to crank but no start. i also tested for power at ecm connector pinout for crank signal and its there. The trigger signal is supposed to come from ecm if I am reading schematic correctly.

Seems funny that i could restart truck 100 times even though it was throwing the p0601 code and now nothing at all after only disconnecting batteries for a while.

It is not low on battery, I even hooked up booster cables from my other truck to be sure

Ideas?
 

·
Registered
Joined
·
4,405 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Yeah very similar
I did check the wires at the alternator bracket, some wear on one wire but i checked continuity ok
Hopefully a reflash will solve, looks like i need a tow to the dealer
 

·
Premium Member
Joined
·
17,806 Posts
Try this--make sure the batteries are full charged.
Follow the pass key relearn process. Never turn key to off, open doors or window.

The key has nothing to affect in these years.

Follow this procedure.

Passkey Security (VATS) Relearn Procedure

01-10

NOTE: The accessory key position is never used in this procedure. If at any time the
vehicle starts and runs normally, you can skip the remaining steps. You are done.

1. Disable your headlamps (parking brake apply, don’t remove any relays or fuses).

2. Attempt to start the vehicle. Vehicle may or may not 'fire' and quit. Release to “run”
position. Some vehicles will not engage the starter. This is normal. DO NOT TURN
OFF KEY YET !!

3. Leave the key in the "on" or “run” position, until the 'security' light goes out or quits
alternately flashing between "Security" and "Battery". This relearn period always takes
10 minutes.

4. After security light off, turn the key to “OFF: Wait 5 seconds.

5. Repeat the above procedure (steps 2 through 4) 2 additional times for a total of 3
start-relearn-attempts, remembering to turn the key to “OFF” (not run) between
each 10 minute relearn procedure. On the third cycle, it will ignore the VIN differences
in the various modules and will start. THIS WILL TAKE 30 MINUTES--NO LESS.
If the 4th start attempt fails to start the vehicle you did one relearn step (or all of them
incorrectly). If you left your headlamps on until the battery went dead and voltage
dropped below 10.5 volts, charge them before proceedng!!
 

·
Premium Member
Joined
·
17,806 Posts
Moved to LLY-- no further info from OP
 

·
Registered
Joined
·
10,681 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
I am having trouble with step 3
After start attempt with key in run position, after about 1 min security indicator illuminates, but it stays on. I waited 15 min on first cycle and it didn't go off or flash?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #9 ·
couldn't get this to work

Ended up towing truck to dealer, tech checked it out and reports failed ECM
Quoted $1800 CDN for new
 

·
Registered
Joined
·
13 Posts
Any update on this. Same thing here, P0601 with random no crank, no start. Did the new ECM fix the problem.
 
1 - 10 of 10 Posts
Top