Chevy and GMC Duramax Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I'm installing the HSP Y-Bridge Kit with both intercooler tubes and inlet horn. I just finished installed a CP3 fuel pump - and that was a freaking bitch and a half!

So....
How in the hell do you get the freaking bolts started on the freaking Y-Bridge?? I have been banging my head for the past 3 hours trying to get the Y-Bridge on (yea, 3 hours on just trying to get it on - been 3 days that I have been working on the truck).
I cannot seem to get ANY of the bolt started no matter how hard I push on the Y-bridge, and yes, the nuts are completely removed from the studs - it is sitting where it goes, just wont go down far enough to install any bolts.

Thanks in advance!
Mike
 

·
Registered
Joined
·
22 Posts
extensions etc check out truck master on you tube he has a video or two on it some good tips. take a cloth or paper and put it on socket then force nut into socket, that will hold nut there then long extensions. its a PIA but patience.
 

·
Registered
Joined
·
21 Posts
when i did my CP3 conversion a few weeks ago I used clean diesel to lube the new o-rings and it helped it slip down.
 

·
Registered
Joined
·
149 Posts
You need to lube the o-rings. I put some o-ring lube on both the y bridge and the intake runners, then slipped it in place and pressed down on it. It helps also to get the front top two bolts started and threaded in, then rock it backward slightly to get the rear bolts started.

Just be careful not to pinch or roll the seals. Otherwise you'll end up doing it again since it will have to come back out to replace them.
 
1 - 4 of 4 Posts
Top