Chevy and GMC Duramax Diesel Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
So I got a quick question. Is there any light or method of seeing if the truck see's the trailer brakes? My 05 had aftermarket and it had a light...Sometimes I would have to wiggle my connector around before the brakes would detect and operate. I put a new plug on it so I assumed it was just an issue with my truck. But now with my 2010 I'm not seeing anything thats saying it's detecting the brakes.

Thanks
 

·
Registered
Joined
·
380 Posts
My 08 doesnt tell you, I think the gain will not show anything on the screen if the trailer is not plugged in. Im not sure, but my RV brakes make a tiny spring squeek when you hit the brakes. I cant help too much, Im in Afghanistan.
 

·
Registered
Joined
·
566 Posts
Im not posative but it should say something when you first plug in a trailer.

Some one will know......Bump.
 

·
Premium Member
Joined
·
93 Posts
Once the trailer wiring is connected, you should be able to scroll through your DIC and see the option for trail brake gain. Also, if you simply squeeze the brake controller (while connected), it should automatically pull up on the screen. If that does not appear, you may have to go to the dealer and make sure everything is connected properly within the truck wiring. I've read here that some of the newer trucks go out the door not fully connected at the rear. Ground wire or something. Hope that helps...
 

·
Premium Member
Joined
·
17,806 Posts
Some have found out that you have to plug in the trailer before you start the truck, or it will not recognize the trailer. :)
 

·
Registered
Joined
·
82 Posts
On my 07.5 as soon as I plug in a trailer with brakes the DIC comes up with the Gain option, I did have once where the plug was loose but the DIC said to check the Trailer plug, also to if you dont know if its connected try to manually use the trailer brakes on the break controler you will feel the truck pull back, I always try this just to ensure I am getting enough breaking
 

·
Registered
Joined
·
1,239 Posts
My 08 doesnt tell you, I think the gain will not show anything on the screen if the trailer is not plugged in. Im not sure, but my RV brakes make a tiny spring squeek when you hit the brakes. I cant help too much, Im in Afghanistan.
come home safe, good luck be with you :drink
 

·
Registered
Joined
·
140 Posts
Wait....there is a brake controller built into the lmm's? I have a aftermarket one I pulled out of my 1500 and needs to be put in the new lmm, but if I have one already no need for that.
 

·
Registered
Joined
·
183 Posts
My 07.5 did same as "beattie". The DIC would come on with trailer gain.
 

·
The Good Son!
Joined
·
1,966 Posts
My 08 and 09 LMM's say "trailer connected" as soon as I plug the cable in.
 

·
Registered
Joined
·
566 Posts
Setexan, Thats what I thought it said but wasnt 100% sure.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #13
Well the DIC does show when I plug the trailer in, but it is just dashes ------ and when I try and manually operate the brakes, it sure as hell doesn't feel like it's braking at all
 

·
Registered
Joined
·
82 Posts
You can adjust the level by hitting the "+" or "-" on the controler it self
 

·
Registered
Joined
·
14 Posts
Discussion Starter #15
I adjusted it all the way to I believe 4.0 and still got no braking. Shouldn't it display something other than ----- too? I mean thats how it looks when no trailer is connected. You'd think it would change?
 

·
Registered
Joined
·
82 Posts
Try putting a test light on the pin for the electric brakes see what happens it could be a wire has popped out on the truck or trailer plug
 

·
Registered
Joined
·
220 Posts
LMM intergrated brakes

I adjusted it all the way to I believe 4.0 and still got no braking. Shouldn't it display something other than ----- too? I mean thats how it looks when no trailer is connected. You'd think it would change?
Read your owners manual, it will tell you what to check in the way of wiring and fuses. Some trucks leave the dealer without a wire connected or without a fuse inserted. I would take it to the dealer and make them do it, also make them check the hot wire to the trailer. Mine was not charging the battery so I had to take it back and make them wire in the right connection
 

·
Registered
Joined
·
14 Posts
Discussion Starter #18 (Edited)
Try putting a test light on the pin for the electric brakes see what happens it could be a wire has popped out on the truck or trailer plug
Will do

Read your owners manual, it will tell you what to check in the way of wiring and fuses. Some trucks leave the dealer without a wire connected or without a fuse inserted. I would take it to the dealer and make them do it, also make them check the hot wire to the trailer. Mine was not charging the battery so I had to take it back and make them wire in the right connection
Yah I gotta take it in tomorrow anyway, fricken dome light button sticks, so I'll have them check that too. Thanks for the input guy's.
 
1 - 18 of 18 Posts
Top