Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I drove my truck yesterday and it was fine, I went to start it this morning and nothing no lights no switches work can't get it to do anything.. I figured the batteries must be dead for some weird reason but they checked fine, so I took my wife's truck to work so I haven't had a chance to really look at it. I am guessing I must have a bad ground? but I can't find a schematic or anything on the web. Its a 2003
 

·
Registered
Joined
·
77 Posts
Check all the +/- connetions from the batteries first !
 

·
Premium Member
Joined
·
17,806 Posts
Sounds like loose connection, or batteries are gone-[my guess].

How did you test the batteries-?? Try this-- turn on the headlights, check the voltage ar the jump start terminal at the power steering pump. 12 + volts-? If not, follow back to the batteries. Try that with each battery, as the other is disconnected.
 

·
Premium Member
Joined
·
17,806 Posts
Moved to LB7
 

·
Registered
Joined
·
164 Posts
Try this (Assuming the Left Battery is Good, and Positive (BATTERY) & Negative (GROUND) Connections are good):
1. Turn Head Lights "ON".
Do they Shine? If "YES" Do Step 2.
If they don't shine, check Batteries or associated Wiring Connections.
2. If they shine, Put Foot on Brake, and Try Putting Truck into PARK AGAIN (to make Park Switch).
If Manual Tranny, DEPRESS CLUTCH PEDAL.
3. Try to Crank the Engine, by turning Ignition to "START".
If nothing works check the following Four fuses:
IGN A (40 AMP)
IGN B (40 AMP)
CRANK FUSE (10 AMP)
IGN E (10 AMP)
4. Replace any defective fuses.


REF:
 

Attachments

1 - 5 of 5 Posts
Top