Chevy and GMC Duramax Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi I have a 07’ deleted, EFI live. Within the last 2 weeks a loud noise has developed that you can hear really well in the cab, it sounds like the AC/heater is on full blast (except a little louder) and it gets louder with the more throttle you give it. When you pop the hood and rev the motor you can hear the blowing noise, it sounds like its coming from the rear of the turbo/ down pipe area, so I took a inspection mirror and flashlight and ran it up and down the firewall looking for a crack in the down pipe. Nothing. It just dumps coal now while accelerating from a stop or going up a hill, I hate being that guy so I keep the tranny in manual mode and try to keep the RPM’s up so I’m not smoking everyone out, I have noticed a loss of power too. I recently (3 weeks ago) installed the EGR pipe delete (before I had just had the blocker plate so it could pass a visual smog check) but it ran fine for about a week before all this came up, so I’m not sure maybe it’s related or a coincidence? Anyways I tested for boost leaks with leak soap, cold/hot/intake. Nothing. I normally have my monitor set to watch other stuff, but today I set it to boost and I can only build 10lbs under hard acceleration. It has 186,xxx miles. Thank you for any help or suggestions!
 

Attachments

·
Premium Member
Joined
·
4,543 Posts
crack in the bellows of the Up Pipe maybe? Not uncommon if you did not change it to an earlier type without the EGR take off.
 

·
Registered
Joined
·
580 Posts
If I had to guess I would think you have a boost leak at the y-bridge, not too uncommon when running EGR delete pipes on the stock y-bridge, especially if it's an ebay special pipe.
 
1 - 3 of 3 Posts
Top