Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 18 of 18 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
This is extremely frustrating. This all happend today and I don't even know where to start looking to fix the problem. I have a 2007 3500hd with the LMM, 2wd dually. Today I was driving down the freeway with th cruise control on and I hit a bump and the cruise shut off and would not come back on. I continued on and the tranny started surging and then my ac shut off and my guage cluster shut down but the truck stayed running. I pulled over and shut the truck off and it would not restart. It would not even crank. I checked all the fuses and they were good. I ended up removing the main fuse panel under the hood and pluged it back in and the truck started up like nothing was wrong. 30 mins later it happend all over again. I repeated my previous steps 4 times to get me home. Please help as I have no clue what could be the problem. Thanks in advance.:help
 

·
Registered
Joined
·
456 Posts
Make sure your battery terminals are tight and clean. Maybe a loose ground somewhere. Maybe a short somewhere.

Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
2,572 Posts
Have the batteries load tested.
 

·
Registered
Joined
·
1,338 Posts
Check with the dealer to see if it needs a body control update.
 

·
it stinks and whistles :)
Joined
·
5,349 Posts

·
Registered
Joined
·
1 Posts
Ryan 4x4 did you ever solve your problem I have the same issue with my 07 4x4 dually. Im also getting service 4x4 and service trailer brake messages. It only does this sometimes and its starting to do it a lil more often.
 

·
Registered
Joined
·
4 Posts
what was the fix, i have a 2008 2500hd with the exact same issues....please reply
 

·
Registered
Joined
·
9 Posts
I had a similar issue. I stopped at a fuel station and shut it off. I tried starting it but it didn't even try to crank. Starter fuse was blown. I replaced it and it immediately blew again when I turned the key. Towed to dealer. Dealer put in fuze and it started right up!! They told me that they tried it multiple times and couldn't find anything out of the ordinary. I told them keep it till you find it since I was only two miles from home and next time I might not be so lucky. Anyways what they had to do was pull on the wiring harness in different areas. They found a wire grounding out somwhere by the power steering pump area. They fixed the wire and no issues since. Probably not exactly same as yours but maybe a different wire for you. Hope this helps.
 

·
Registered
Joined
·
1,743 Posts
Sounds like there is a loose wire or a wire grounding somewhere.

Will just take time to track down.
 

·
Registered
Joined
·
4 Posts
ok great i will check once i get home...the truck that had the wire grounding out around the power steering pump, was it an LMM truck?

thanks again
 

·
Registered
Joined
·
9 Posts
Yes it's an Lmm. I'm not sure why my sig didn't show up. It only had 72k on it when it happened.
 

·
Registered
Joined
·
4 Posts
ok thanks, didnt get a chance to look at a whole lot but so far have not found anything...its been in the no crank status for the past week and its driving me crazy. almost to the point of taking to dealer
 

·
Registered
Joined
·
4 Posts
I finally got the Duramax fixed...i took it to the dealership after believing it was a faulty Body Control Module, because any OBD II tool would not link with the Engine Control Module. Bought a new one for 300 bucks and it turned out not to be the problem. Buddy of mine found a loose wire in the wiring harness on top of the engine just to the right of the black plastic labeled 6.6 Liter Duramax on top of the engine.

just glad that its fixed
 
1 - 18 of 18 Posts
Top