Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Alright this is going to be a long post.
Well I have to say, I joined this forum yesterday to ask one question, but as it turns out I have many, many questions. Rather than post multiple times, as I have already done. I am going to ask all my current questions in this thread. BTW this forum is great! The answers are quick and make lots of sense. NICE!

Here we go:
I bought a 2001 2500HD extended cab, short bed 1.5 years ago. ~183000kms. Previous owner was good about regular maintenance (oil changes etc...), but lacked appearance care (i.e washing and oil spraying). I keep the truck will maintained (i.e get the oil/filter changed regularly), but drive the truck relatively hard. Don't tow that often. No engine mods. The only 'mods' I have done are minor. I have Sirius Radio, some weather tech vent visors (which are the best I have ever seen) and some license plate covers (haha). From reading the forum I apparently have the LB7 engine and I desparately need to change the fuel filter. I upgraded from the stock tires to P265/75 R16 (stock rims, but I keep them real clean!). I also need to replace the overload spring o-rings.

Here are my questions:

1) My fuel gauge is jacked. The needle always sits on empty with the low fuel light on. Occasionally it snaps up to 3/4 full for a few minutes and the light turns off. I re-fuel based on the trip odometer and it has only bit me in the a$$ once (rush hour, busy road, stalled right at the lights - oops). Do I need to drop the fuel tank to replace the sending unit? Don't want to spend the $600.00 or so I was quoted just for the fuel gauge. Should I wait for the tank to start to leak? Will it ever leak? The rest of the gauge cluster seem to work fine.

2) My airbag light is always on. Not flashing, just on. I have not seen any codes that indicate anything is wrong, but I would like to get the light to turn off. Thankfully, I have not had to test the airbags to see if they work so I don't know. Anyone know the fix for this?

3) Rocker panel rust. Has anyone re-painted the lower half with, for example, the spray on bed-liner stuff or a similar product. I have the stock mud flaps but the paint is completely gone behind the rear tires and above the running boards is getting pretty gnarly, rust wise. I live in Canada and we salt the $h*! out of our roads in the winter. I try and clean the truck regualrly, but the doors freeze shut when it is -30 out.

4) My running boards are rustin' up real nice. I have the stock chrome finished tube running boards. I am getting tons of rust on them and my driveway is stained with rust where my truck sits. Anyone got these powder coated or repainted or anything? I have the ability to sand blast and powder coat them, but I don't know if I can remove the plastic step without damaging it permanently. Is it just snaps or if I pull it off will I break it?

5) My truck pulls to the left occasionlly under heavy braking. Not all the time, but once in a while it pulls noticibly to the left as I brake. Nothing crazy and it doens't feel unsafe, I just notice you have to steer right sometimes. Also way more brake dust on the left front rim than the right. Anyone else experience this, or is my garage just not doing a good job? I had the brakes serviced a few times since I bought the truck.

6) My parking brake doens't do anything! Had the parking brake fixed after I bought the truck, but if I park on even the slightest incline and set the parking brake, the truck rolls away as if there were no brakes on at all. I have an automatic, but I figured I may as well set the parking brake as most automatics have just a tiny plastic pin to hold the entire vehicle. Is this typical or these trucks or is it a mechanic issue. I don't live in a real hilly area, and it has not been a problem up to know, but since I am posting questions.

7) Passenger side window. This is a two part question
a) Can I replace the non-autodown switch with an autodown switch similar to the driver side to get the autodown option, or is it more work to get the passenger side to become autodown?
b) When I am putting the passenger window up it seems to really struggle, almost as if it is not going to make it. Both window motors and the cables (?) were replaced some time ago, before I bought it. Is this typical? Is there a fix for this?

8) only one fog light works. My driver side is burned out. I have replaced the bulb a few times but the connector seems to be the problem. Has anyone gone with an aftermarket fog light with success? I like the look of the stock rectangular lights, but only when both of them are working!

alright that is all for now. I wonder if this is the longest post yet???

Thanks in advance for all the answers!
 

·
Hi, I'm Earth. Have we met?
Joined
·
3,162 Posts
I can help with 1 & 2 more than likely its the instrument cluster its self going haywire, they are more than well known for not working right. You could get a new one from gm, a junkyard or even PPE sells them also!!
 

·
Received a Hummer
Joined
·
9,627 Posts
I'll try some of these.

3. Check your warranty...it might be covered.
4. I've tried repainting running boards before...and unless you can get ALL the rust off...inside and out...it's not worth it. It will just keep rusting through.
5. I was always told by mechanics...if your vehicle pulls to left or right when the brakes are applied...then its your Routers, Roters (spelling?) Get them shaved if possible or buy new.
7. I believe if you replace the switch..you will have to do Driver side and Pass. side...and it would be a pain. As for the passenger side being slow...my Avalanche did that..and 2 Garages from GM told me that it was typical and wouldn't hurt anything...and they wouldn't fix it. My truck was still under warranty too.
8. It isn't hard to replace the wiring if you have a basic knowledge of electric work...I've done it twice before and I'm by NO MEANS and electrician.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
Thanks. As for the brakes question and response, it only pulls to the left occasionally during heavy braking, I might go a couple of days with it working fine, then one day it will start to pull to the left for a while then it will go away. I also had the rotors replaced when I got the truck at 142000kms, so they only have 80k on them. This is a relatively new issue as well.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
Thought of another question on the way in this morning.

How do I remove the A-pillar trim? Do I have to pull the dash off first, or does the A-pillar trim come off first?

(I think I may be addicted to this site)
 

·
Received a Hummer
Joined
·
9,627 Posts
I've always had to replace my rotors after about 50K. So in my opinion...80K on rotors seems like alot...but I might be mistaken.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #7
I've always had to replace my rotors after about 50K. So in my opinion...80K on rotors seems like alot...but I might be mistaken.
sorry I am only at 40oookms on the new rotors. I will get them checked out tomorrow anyway.
 

·
Diesel Addict
Joined
·
7,754 Posts
I've always had to replace my rotors after about 50K. So in my opinion...80K on rotors seems like alot...but I might be mistaken.
105k on my 05 LLY and still runnin the orriginal shoes and rotors..
613duramax
just a thought if it is pulling when the brakes are applied couldn't it be a caliber or the master cylinder..
one question for ya 613Duramax do you really have P series(4ply)tires on your truck,if so get rid of them especially if you tow any?
 

·
Registered
Joined
·
18 Posts
Discussion Starter #9
I had the size right but the letters wrong.

I am running the Michelin LT265/75R16
NOT the P265/75R16
 

·
Diesel Addict
Joined
·
7,754 Posts
I had the size right but the letters wrong.

I am running the Michelin LT265/75R16
NOT the P265/75R16
allright,just thought i would ask..
 
1 - 10 of 10 Posts
Top