Chevy and GMC Duramax Diesel Forum banner

4561 - 4580 of 4603 Posts

·
Premium Member
Joined
·
8,966 Posts
Discussion Starter #4,561
I passed you somewhere between Buckeye Lake and Zanesville. That's dang early to load man! I figured you had loaded on Friday. I didn't leave the house till 5 so I'm guessing it was about 6:30 - 6:45.

They say it's good to be busy.
Yeah, I left Zanesville a little after 6.

Hoping to recharge a bit here in few weeks in Florida for a 2 week vacation.

We’ll have to catch up over lunch or dinner sometime. Haven’t seen you in a good while.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
8,966 Posts
Discussion Starter #4,562
Sorry Matt - I'll keep quiet and just watch!
Haha, no worries, Dave. I don’t believe I jinxes. It is kicking my butt tho, even if it’s my own fault.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,210 Posts
For sure man, if I'm ever home. I drove out to MD this morning. Spending the week in the hot-box out here. CENLA will be next month for me. You must have been headed back over my way if you were on 33.
 
  • Like
Reactions: M.A.M.

·
Premium Member
Joined
·
8,966 Posts
Discussion Starter #4,564
For sure man, if I'm ever home. I drove out to MD this morning. Spending the week in the hot-box out here. CENLA will be next month for me. You must have been headed back over my way if you were on 33.
Headed for Defiance. Up 33 to 117 towards Lima.

Maybe we can round up a group of guys again for lunch or dinner later this summer once things slow down.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
8,966 Posts
Discussion Starter #4,566
Found a bit of time Saturday to get a little done on the truck again. Up-pipes are bolted down, turbos are both in and have the oil feed/drains run. Just new to run a few battery wires yet, and finish up the piping and we’ll be good to go.




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
18,273 Posts
Found a bit of time Saturday to get a little done on the truck again. Up-pipes are bolted down, turbos are both in and have the oil feed/drains run. Just new to run a few battery wires yet, and finish up the piping and we’ll be good to go.




Sent from my iPhone using Tapatalk
Nice Matt, can't wait for it to be up and running again.

Sent from my VS988 using Tapatalk
 
  • Like
Reactions: M.A.M.

·
Registered
Joined
·
1,235 Posts
That's an awesome picture. Valley charger peeking out of the background with a hint of SDP
 

·
Premium Member
Joined
·
8,966 Posts
Discussion Starter #4,572
Really hope I can maybe get it running this week sometime. Gonna be some odds and ends to wrap up, but hopefully I can cruise it around this fall yet before nasty weather hits.

Hoping to get it in the dyno at King of the Street challenge, and maybe hit the dirt drags.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
8,966 Posts
Discussion Starter #4,573
Really hope I can maybe get it running this week sometime. Gonna be some odds and ends to wrap up, but hopefully I can cruise it around this fall yet before nasty weather hits.

Hoping to get it in the dyno at King of the Street challenge, and maybe hit the dirt drags.


Sent from my iPhone using Tapatalk
Got the truck running yesterday. Man, it feels good to hear that again!

Had a bunch of little stuff I had to run after all day. Switched over to a single battery, so I had to get a few of the cables redone. Popped right off on the fourth cycle of 15 second cranking intervals. Let it run for a while, and got it up to temp. No fuel, coolant, or oil leaks, so I think we’re good. Got a little this and that to clean up and tidy yet. A few wires that need to be wrapped in Tesa tape. Need to put the bed back on as well.

No check engine light, but the ABS light was on. Wanted to open up the ABS info on the scanner to check the sensors, but I can’t access it. Seems like it’s not communicating at all. Need to get that figured out as soon as I put the driveshaft back in and can pull the truck out. I broke one of the speed sensors when I was painting the axle, but I replace that with a brand new one, so it shouldn’t be that. Hopefully something simple. Still need to bleed all the brakes since I replaced all the soft lines with stainless lines. Plenty of air in them I’m sure.

I want to keep the truck plugged into a trickle charger/battery tender whenever it’s parked in the garage, especially over winter. Any recommendations for a quality one that I can just plug in and ignore?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
5,494 Posts
I use a Battery Tender for my small batteries. It's a 3/4 amp maintainer. Anything bigger, I use a NOCO Genius 3 amp. It was ok when I was having some power issues last winter.

When things get really bad, I go back to an old manual one that is over 20 years old. It will work when the automatic ones won't.

Sent from my SM-A705W using Tapatalk
 
  • Like
Reactions: M.A.M.

·
Premium Member
Joined
·
8,966 Posts
Discussion Starter #4,575
What kind of power issues were you having? It’s a brand new battery, so just don’t want it to discharge totally.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
5,494 Posts
I had some ground issues and corrosion on the alternator feed. My batteries would discharge over 2 days.

When I put the SDP Y bridge, turbo and up & down pipes on, I cleaned all the connections and everything started working better. The alternator seems to perform better without the grid heater.

The voltage is more stable. I don't really know which one solved the problems.

Sent from my SM-A705W using Tapatalk
 
  • Like
Reactions: M.A.M.

·
Premium Member
Joined
·
8,966 Posts
Discussion Starter #4,577
Got the ABS light issue figured out. I was pretty sure I missed a ground somewhere, bothered me all day today. Sure enough, tucked up above the frame behind the wire harness. Bolted that to the frame, and the abs module came alive, and the lights went out.

Also got the rear driveshaft installed this evening. Started it up again just because I can. Got a buddy coming over tomorrow evening to help bleed the brakes son that I can pull it out of the shop and back in, to set the cab back on and bolt it down.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
18,273 Posts
Got the ABS light issue figured out. I was pretty sure I missed a ground somewhere, bothered me all day today. Sure enough, tucked up above the frame behind the wire harness. Bolted that to the frame, and the abs module came alive, and the lights went out.

Also got the rear driveshaft installed this evening. Started it up again just because I can. Got a buddy coming over tomorrow evening to help bleed the brakes son that I can pull it out of the shop and back in, to set the cab back on and bolt it down.


Sent from my iPhone using Tapatalk
Good to hear Matt, need to get yourself some speed bleeders, look them up.

Sent from my VS988 using Tapatalk
 

·
Premium Member
Joined
·
3,487 Posts
The harbor freight bleeder that hooks to your air compressor is really nice. 1 person job, and can do all 4 in like 10 minutes. Just gotta keep an eye on the reservoir so you don't run it empty.

Sent from my SM-N960U using Tapatalk
 

·
Premium Member
Joined
·
8,966 Posts
Discussion Starter #4,580
Good to hear Matt, need to get yourself some speed bleeders, look them up.

Sent from my VS988 using Tapatalk
I feel like you’ve told me already about these, and I never ordered. Definitely will check them out.


Sent from my iPhone using Tapatalk
 
4561 - 4580 of 4603 Posts
Top