Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Long story, but I am at a crossroads and need any advise. I have an 03' 5-speed that I replaced trans with junkyard model @150k because output housing cracked (U-joint vibration). Now I am at 210K miles and that junkyard one has gone out (slipping sludge, unknown miles). I replaced tail housing on the known good original transmission (150k one that was stopped immediately when lost fluid and put in shed dry for 5 years). The shop just installed this transmission in the truck with new solenoids, internal wire harness, and cleaned valve body internal. I also replaced case half of T-case due to pump rub.

Here I am with transmission in and it will not move correctly. Shop said it wouldn't go in reverse. When I went the next day it went in reverse. I drove it about a mile down the road and then stopped in parking lot. It wouldn't move. It just slipped then either went roughly into gear for a few second (then limp), or went straight to limp. I restarted it 20ish times to clear "range shift inhibit" and got it back to the shop. Shop thinks the problem is internal. I don't know. Any advise? Do I need to just get a newly rebuilt one?

-Fresh Convert from Diamond-T
-Fresh Solenoids
-Fresh Internal Wire Harness
-Split, cleaned Valve Body
-New T-Case half
-150k transmission original from truck with aft extension housing replaced. Known good, but sat dry for 5 years.

Any info or thoughts are appreciated
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Just got the codes from my mechanic. It's a bunch.

3/19 5:26PM
P0700 -Transmission Control System Fault

3/19 5:28PM
P0735 - Incorrect Gear 5 ratio
P0843 - Transmission Pressure Switch Solenoid "C" Circuit High
P0847 - Transmission Pressure Switch Solenoid "D" Circuit Stuck Closed
P0848 - Transmission Pressure Switch Solenoid "D" Circuit high
P0872 - Transmission Pressure Switch Solenoid "E" Stuck Closed
P0875 - Transmission Pressure Switch Reverse Circuit
P0701 - Transmission Control System Out Of Range

3/19 5:50PM
P0843 Transmission Pressure Switch Solenoid "C" Circuit High
P0875 - Transmission Pressure Switch Reverse Circuit

3/19 6:30PM
P0841 - Transmission Pressure Switch Solenoid "C" Stuck Off
P0875 - Transmission Pressure Switch Reverse Circuit


1086484
1086485
 

Attachments

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
I made the hour drive out to the shop tonight after work.

Apparently the shop thought the same thing as you Mike L.. They fired it up back on the 19th and got all kinds of codes. They disconnected the main connector and reseated. I think that is why a large portion of the codes disappeared. I did check all connections and didn't find anything.

After verifying that all external electrical connections looked good, I started the truck. It is still doing the same thing. It will drive some, slip, then limp.

I noticed one very important thing. When shifted into reverse or drive the truck is trying to push through the brakes. I noticed it because you could hear the turbo spooling under load just sitting in drive. Does this possibly mean I have a bad torque converter (new from Diamond-T, https://ktperformance.net/search.html?q=gs0155 )?

Another thing I noticed is the vehicle park indicator matches what you select with the lever, but sometimes when it is in part the vehicle advisory "dings" and the dash indicated "driver door open" if I open the door in park. It doesn't seem to do this every time, but makes me think the NSBU switch may be out of adjustment or something. I asked the mechanic to reinstall the original (housing damaged at plastic latch area that holds the cannon plug), in order to rule out this part.

I really don't want to spend half the value of this truck on a rebuilt transmission. Thank you Mike L. for the insight. Any other thoughts on this?
 
1 - 5 of 5 Posts
Top