Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
I recently bought a 2005 gmc sle.It has 185,000 miles.I changed fuel filter ,oil ,and the screw on trans.filter before a road trip.250 miles into trip running 75-80 truck lost power and would not turn over 2000rpm.Turned truck off 're started and made 100 more miles before did it again.I can start truck up and can rev to any rpm.I can go down road and when it gets to about 2300-2500 rpm won't rev any higher then it bogs till you go below 2000 rpm.It will run and shift fine as long as you don't go over 2000 rpm.Once truck reaches the 2300-2500 rpm range if I let out of it it never goes into limp but if I get it to the 2300-2500 rpm and hold it ther trying to make it go after about 2-3 second it will go to the limp mode.I'm getting no check enginr light. Any help will be greatly appreciated
 

·
Registered
Joined
·
7,904 Posts
Sounds like your fuel presure relief valve (fprv) is opening. Do a search for "bottle test". If it fails the bottle test it's a easy fix, you'd have two options.

Option 1. race plug
Option 2. Fprv shim kit
Both are less then $50
 

·
Registered
Joined
·
7,904 Posts
I shimed mine. Prolly should bottle test it to verify it is the problem tho.
 
  • Like
Reactions: tofast8350

·
Premium Member
Joined
·
26,484 Posts
If you have no DTC codes, it isn't a fuel limp. It does sound like you're starving for fuel...low tank levels, clogged filter, leaks in filter head and/or supply lines sucking air....with close attention paid to the soft lines at the filter head.

^<-Those age, crack and become soft, sucking flat like a straw, which would mimic exactly what you've described.
Replace with 1/2" bio-compatible bulk fuel line, instead of the $85 OEM lines from the Dealer.

 
  • Like
Reactions: tofast8350

·
Registered
Joined
·
89 Posts
how cold is it ? your fuel might be gel'd over in your lines and tank and is building up . I had that problem last year had to go through 2 filters until it cleared up , then it was the end of limping .

also do you have any kind of engine monitor ? Cel (check engine) lights ? anything ?
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #9 ·
Tempature isn't the problem been lows in 40s and 50-60 during day.Noticed my primer on filter head is sucked down when running may be obstructed coming from tank
 

·
Registered
Joined
·
89 Posts
sounds like its time to rebuild the filter assembly , also there are two lines coming out of the tank in the back a return line and a to the filter line , they are braided hose I think they are both 2 foot sections , when that hose gets tired it collapses under high speed , just like hookem horns said don't use the oem hose , find a hose shop and get the heavy duty stuff , I am not sure what the number or what the rating is , but if you do a forum search someone else lists what to do to replace them . basically they collapse under high speeds , which sounds like it could be happening , that problem if I am correct was a factory recall as well .
 
1 - 10 of 10 Posts
Top