Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I have posted on this before and have been trouble shooting different ideas. I have had a DSP5 tune from SSDieselTuning that ran perfectly. Nice crisp shifts and then literally overnight the symptoms below started after 4-5 months of the tune being on the truck. I switched over to the stock position on the switch and have been driving it that way for months. Tuesday night I became fed up and decided to reload the stock tune and sell my V2. For fun I reloaded a single tune that has "425 rwhp" and viola - Trans is shifting fine. Back to DSP5 and the problems are back again.

ANY IDEAS?? Can a tune or DSP5 switch go bad and cause this?

Symptoms:
Change Fuel Filter Message
Very long (not defuel) delay between shifts

Changed Fuel Filter several times
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #2 ·
Bump - No thoughts from anyone?
 

·
Registered
Joined
·
10,681 Posts
on my 06 LBZ I had the same issue. It was at the harness where the DSP ties into to. The connection got loose over time and wouldn't work. i ad to replace with a new switch and pins. Mine never would work right seems the pins would not hold tight
 

·
Registered
Joined
·
1,409 Posts
^ um 08 is an lmm...
Yes lbz plus the emmisions crap but still an lmm. Am i missing something here?
I cant comment on the dsp5. Never had one. :(
 

·
Registered
Joined
·
2,572 Posts
What is the voltage at the switch
 

·
Registered
Joined
·
10,681 Posts
^ um 08 is an lmm...
Yes lbz plus the emmisions crap but still an lmm. Am i missing something here?
I cant comment on the dsp5. Never had one. :(
Ooops, fixed it, it was my 06lbz
 
1 - 6 of 6 Posts
Top