Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 9 of 9 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter · #1 ·
I am working on an 05 LLY with 144k miles on it. It keeps going into limp mode with a p0087 code. I checked the balance rates with a scanner and injector 2, and 5 are out of spec. This truck just came from the dealership and they replaced these 2 injectors already and they are still high. The fuel filter has been changed twice since this started. Just looking for some advice on what to try. This truck is stock.
 

·
Premium Member
Joined
·
17,806 Posts
Check the fuel hoses by the driver's side of the trans-- There was a GM_TSB on this problem and also will set the 0087 code..
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #4 ·
Its not tuned. ill do some research on the TSB
 

·
Registered
Joined
·
7,912 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter · #6 ·
Bump anyone have any other ideas
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #8 ·
I just got back on this truck today. while i was checking things out i had someone power break it, the motor mounts are terrible. I can tell it is pulling on the wiring harnesses on the drivers side. Is there any wires or fuel lines that could be my problem because of the motor mounts. Just wondering if anybody has ran into this before
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #9 ·
Also have a p1093 code
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top