Chevy and GMC Duramax Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
First of all I have a 2004 Chevy Duramax 2500 HD crew cab. Making a haul to the trash dump started throwing thick black smoke a horrible power loss and check engine light came on. Nursed it back to the house put the code reader to it spit out turbo boost sensor. Talked to some people and decided a replacement sensor was in order. Boost sensor has been installed turned off the code. Took her for a drive this time no power and still poping a code for the turbo boost sensor. No black smoke this time though. It's so bad with power it's like I have a 40 HP VW engine in the truck.

Anybody got any ideas on what I need to look at next?
 

·
Im Superrrrr!
Joined
·
14,517 Posts
check the intercooler tubes/boots and clean your MAF.
 

·
Registered
Joined
·
19 Posts
sounds like you may have lost your intercooler boot. if you remove one just for fun you can make all kinds of black smoke but you will have no power. just check all the clamps and make sure they are tight and your not sucking air someplace
 

·
Its just a worktruck
Joined
·
13,908 Posts
x3 on intercooler boots.
 

·
Premium Member
Joined
·
17,806 Posts
Everyone here is familiar with what the codes mean, best to list the codes.

Also an 04 can have two different engines-- and it does make a difference on possible problems. If you fill out the Signature, under "User CP" at the top, it will show when you comment or ask a question.

LB7-- has a 1 in the 8th digit of the VIN-- a LLY has a 2.
 
1 - 6 of 6 Posts
Top