Chevy and GMC Duramax Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have an 06 lly with 208,000 miles. Previous owner had the trans built at approximately 190,000.
Have had issues with cooler plugging and valves sticking since I’ve owned it. Recently, started truck to warm up and it went into high idle. Came outside 15 minutes later and truck smelled like a dumpster fire, but I didn’t think much of it because the garbage truck had just gone by. Hopped in and started driving, 35 mph about 1 mile then 70 mph on the freeway. Made it about 3 miles on the freeway before the trans was at 250 degrees. Fluid was burnt but no significant amount of debris when I dropped the pan and changed filters. The converter isn’t locking up when cruising, and now the truck hesitates when engaging drive or reverse. Throws a p0757 code and violently downshifts to second gear when I test drive it. Haven’t been using it as transportation since the issue happened. Anyone have any advice or answers to what I’m dealing with? Thanks
 

·
Premium Member
Joined
·
3,323 Posts
Who rebuilt the trans and what condition was it in prior to rebuild? Sounds like the cooler is plugged with burned clutch debris.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
It was toast before it was rebuilt, affordable transmission of white marsh Maryland built it. I read something about the fluid slushing on high idle and starving the converter when it’s severely in the negatives outside, but it was 25 degrees above.
 
1 - 4 of 4 Posts
Top