Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 3 of 3 Posts

Registered
Joined
14 Posts
Discussion Starter · #1 · (Edited)
Hi. I was having some issues with my duramax lmm 2008 3500hd. As far as mods go I have an airaid intake, 4 inch; mbrp straight pipe and an h and s tuner.

I just encountered the code p0299 (engine turbo charger underboost). So I needed to a smog done to register my truck in California and I detuned my truck, restored the computer to stock for the last couple days. When I was driving on the freeway yesterday I pulled up next to a cummins and we both got going. I was pinned for a little while until my truck went into limp mode of reduced engine power. I pulled over and looked up the code through my minimaxx (still no tune installed just checking th code). I looked up some stuff about the code on this forum and came to a conclusion that it was because my aftermarket exhaust without a tuner. I just cleared the code and drove home without a problem.
Was wondering if I should look more into this and get everything checked by a diesel mechanic. I apprieciate your help.
Thanks,
Jack
 

Registered
Joined
242 Posts
I've read it's an ongoing issue with Variable vane turbo's? The limp mode you got its probably low fuel rail pressure from your truck not keeping up with the desired rail pressure. It's a standard thing with tunes as they start producing more power 馃構

Fixes with bigger tunes are;
PPE ported fuel rail fitting
PPE race fuel valve
Lift pumps.

I've got compound turbos with a 4094 stage 2 in the valley and occasionally I still get this. My tuner said its kind of hard to pinpoint if I remember correctly.
 

Registered
Joined
14 Posts
Discussion Starter · #3 ·
Thanks for your help! I was planning on getting a lift pump in the near future (I got the Low Fuel Rail Pressure code P0087 before). But I was wondering if there may be another problem with the turbo because then that under boost code was thrown out I did not have the tuner installed. So there may be another issue?? This is my first diesel truck so I am still learning the tricks to diagnosing some of the problems. Thanks again for your help. Greatly appreciated!!
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top