Chevy and GMC Duramax Diesel Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter #1
I own a 16 chevy 2500hd LML 4x4 and I have recently changed transfer case fluid and front and rear diff. Randomly I get 2 codes, when I'm driving through town(stop and go traffic) P0700-trans control system - circuit malfunction & P2771-4x4 low gear circuit circuit malfunction. What I'm confused about is. This trck has used 4x4 low, probably 2 times its entire life(since i bought it off the dealership lot in 2016) I use 4x4 High everyday to get up my driveway. But always attempt to make sure I'm out 4x4 after i get to the top of my hill.... please help, this is my daily driver. I'm not sure where to begin to look at exposures to wires. Thank you for you're help!
 

Attachments

·
Premium Member
Joined
·
626 Posts
How often are you getting the codes?
 

·
Registered
Joined
·
103 Posts
Discussion Starter #3
How often are you getting the codes?
It was rare. Then, the other day it popped up on my way to work. So, I changed fluid in transfer case and front and rear differentials. After I changed fluids, it was gone. But, then yesterday I was in town doing errands, and it popped up yet again. I have noticed that it's getting harder to put gear shifter in Park.
 

·
Premium Member
Joined
·
626 Posts
Mine does it every once and while as well. I have researched it and talked with others that have had the same codes, and unfortunately, I have not heard of a solution yet. I don’t remember everything that was tried by different people, but a few things were, 4 wheel drive switch, checked the wiring and connections at tcm trans and tc and nothing worked. And one guy put in a new tcm.

It’s hard to diagnose when it is so random. I got the codes maybe half a dozen times the first two years and then earlier this year it happened about 4 times in a month and I thought here we go, something is going to break and at last I will figure it out. Nothing broke and it hasn’t happened since ( I know I just jinxed myself). The concerning thing for you is the putting it in park issue, mine doesn’t have any other issues.

Hopefully you can find the problem or someone else will chime in and help out. I will go back and look at my old conversations about this and see if something doesn’t help.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #5
Mine does it every once and while as well. I have researched it and talked with others that have had the same codes, and unfortunately, I have not heard of a solution yet. I don’t remember everything that was tried by different people, but a few things were, 4 wheel drive switch, checked the wiring and connections at tcm trans and tc and nothing worked. And one guy put in a new tcm.

It’s hard to diagnose when it is so random. I got the codes maybe half a dozen times the first two years and then earlier this year it happened about 4 times in a month and I thought here we go, something is going to break and at last I will figure it out. Nothing broke and it hasn’t happened since ( I know I just jinxed myself). The concerning thing for you is the putting it in park issue, mine doesn’t have any other issues.

Hopefully you can find the problem or someone else will chime in and help out. I will go back and look at my old conversations about this and see if something doesn’t help.
See, the even more weird part is, my transmission doesn't start to act up and shift harder, until that light comes on. Truck shifts fine 1st good 2,3, then going into 4th so rapidly but, I think I am going to do a trans relearn and hope that fixes it. If you don't mind me asking CDMAX16 Cou lml d you tell me the proper procedure to trans relearn process
 

·
Registered
Joined
·
103 Posts
Discussion Starter #9
Bump
 

·
Registered
Joined
·
5,863 Posts
Since the descriptions are 'circuit faults' seems they would electrical issues, rather than a fault with the item(s) being monitored.

P0700 is something with serial communication to TCM
P2771 is a status/logic problem with 4WD Low switch.


Have you verified connectors/harness connected and not damaged?


I'd think changing fluid wouldn't have anything to do with either one -- unless a harness/connector was moved during the process.


.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #11
Since the descriptions are 'circuit faults' seems they would electrical issues, rather than a fault with the item(s) being monitored.

P0700 is something with serial communication to TCM
P2771 is a status/logic problem with 4WD Low switch.


Have you verified connectors/harness connected and not damaged?


I'd think changing fluid wouldn't have anything to do with either one -- unless a harness/connector was moved during the process.


.
I have checked and can only see that the TCM seems to have some play and is not on there tightly. But not completely loose.
 

·
Registered
Joined
·
5,863 Posts
Anybody know if the 4WD low switch fault is refers to the switch on the dash or the sensing device at the transfer case?
 

·
Registered
Joined
·
103 Posts
Discussion Starter #13
Anybody know if the 4WD low switch fault is refers to the switch on the dash or the sensing device at the transfer case?
Are you meaning the SOTF ? for 2wd,4wd⤴,4wd⤵?
 

·
Registered
Joined
·
103 Posts
Discussion Starter #14
Bump
 

·
Registered
Joined
·
103 Posts
Discussion Starter #15
Hey guys, just now got my CTS2 monitor in. But from what I read from cts2 manual my #s are way off. Anyone say is this false or fact?!
 

Attachments

·
Premium Member
Joined
·
9,566 Posts
Balance rates should be checked on a stock tune engine at operating temp. this is per GM recommendations. Rates are within parameters if they are between +4 or -4 when idling in neutral or +6 or -6 with engine idling in drive with foot on brake.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #17
Thanks.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #18
Now having trans issues! It began very vague. But now, it's bad! When putting the truck in reverse, it's fine! But, once I let off the brake, there are one or two loud clunks. Used to, the sound was sometimes hard to hear and only when going into reverse and letting off the brake. But, it has gotten louder and now is doing it "on/off" when upshifting. Usually 1-3
 

·
Registered
Joined
·
5,863 Posts
Are you meaning the SOTF ? for 2wd,4wd⤴,4wd⤵?
Might have nothing to do with it, but I was just wondering if a connection somewhere near the transfer case might have been jostled/moved when doing the oil drains and refills.


It took me many hard lessons to learn to 'first look where the last work done' when diagnosing a new fault shortly after something was worked on.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #20
Are you meaning the SOTF ? for 2wd,4wd⤴,4wd⤵?
Might have nothing to do with it, but I was just wondering if a connection somewhere near the transfer case might have been jostled/moved when doing the oil drains and refills.


It took me many hard lessons to learn to 'first look where the last work done' when diagnosing a new fault shortly after something was worked on.

Thanks for the advice redwngr! Hopefully I'll have an update soon
 
1 - 20 of 22 Posts
Top