Chevy and GMC Duramax Diesel Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I've just had the gearbox completely rebuilt, now the engine is permanently in limp-home mode.
Before the gearbox problems it was running fine.

Does this indicate there is an ongoing problem?
Or is it simply an error left over that needs to be cleared somehow?

Duramax 6.6 / Allison LB7 / Edge in a Hummer H1 - built in 2005

Many thanks
 

·
Registered
Joined
·
437 Posts
Are you able to read any codes? after you turn the H1 off and on a few times is it still in limp mode? And when you say gear box what are you referring to? Tranny, TXFR case, or rear end. An what was going on when it went into limp mode. Some more info might help.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
I don't have anything to read the codes
(I'm keen to get something - any recommendations?)

It's always been in limp-mode since the gearbox (sorry - transmission) was reinstalled. You can turn it on and off as much as you like. Had the battery disconnected for a couple of days hoping it would forget the error - no luck.

The original fault was the torque convertor died.. no drive at all. While the box was out I had the transmission rebuilt by a specialist.
Whilst he's a specialist auto-transmission guy and has done allison's before - he'd never seen an LB7. H1's are kind of rare round here - I've only ever seen one other.

Whilst it had the torque convertor fault it wouldn't move.. but it would rev, certainly not in limp mode.
Since reassembly it's permanently in limp mode.

Probably next step is to get the codes read?
Thanks for the help.
 

·
Registered
Joined
·
437 Posts
IIRC the tranny is no different then ours, there might might be a loose connection to the TCM causing the perm limp since it happened since rebuild, many things could have happened, C4 clutches in wrong, or a non working solenoid or something. Definitely get the codes read, but it sounds like the tranny might have to come apart again. Hopefully a transmission specialist will chime in to try and help. you can always look at this in the mean time.
Good luck and hope you back up and running soon.

http://www.duramaxforum.com/forum/h...1000-teardown-rebuild-no-posting-allowed.html
 

·
Slave to the Interwebs
Joined
·
9,954 Posts
If it is the transmission that you pulled then make sure you got everything electronic hooked back up. I would bet you are getting transmission codes. Something could have gone wrong in the rebuild. You can buy a OBDII scanner for around 100 bucks. You really need to get it hooked up to a code reader.
Which Edge juice do you have? Does it have a monitor? Some of the newer ones will scan for DTCs if you enter the Diagnostic menu
 

·
it goes vroom then bang!
Joined
·
608 Posts
reflash the tranny tcm get a tech 2 and re learn the tcm and you shoulkd be alright. and if you cant get one cycle the ignition key 45 times on off on off that will automatically reset the tcm
 

·
Premium Member
Joined
·
17,806 Posts
Most cheap code scanners will not read trans codes, will only show a P0700, which is only the light for the trans. Check before you buy.
 

·
it goes vroom then bang!
Joined
·
608 Posts
A tech 2 is a gm specific code reader its for all gm vehicles as long as you have that you can relearn the allison and it should take it out of limp if you don't want to buy one go to ur local dealership n have them flash the trans for u I know here in the states its only like a hundred bucks Idk what it would cost you over there.
 
1 - 9 of 9 Posts
Top