Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 20 of 20 Posts

·
Registered
Joined
·
726 Posts
Discussion Starter · #1 ·
So for the past few months my heated seat and the power to my seat has been dead and will only work when it wants to now it’s dead all together. Has any one else had this happen or know how to fix it?
 

·
Oh...... Squirrel!
Joined
·
24,083 Posts

·
Registered
Joined
·
726 Posts
Discussion Starter · #3 ·
O no I wont be taking it any where the last time I did that it cost me 500 bucks when 2/7 injector harness decided to let go out in BFE. I’m savvy with electrical I don’t have a doubt that I can fix it. I was just thinking I can’t be to only one that this has happened to.
 

·
Registered
Joined
·
45 Posts
mine just did the exact same thing. did you figure it out yet?
 

·
Registered
Joined
·
726 Posts
Discussion Starter · #5 ·
mine just did the exact same thing. did you figure it out yet?
I don’t know yet what has caused this. I haven’t dug in to it yet but when I figure it out I let you know ASAP.
 

·
Registered
Joined
·
47 Posts
My last truck (03 ec 4x4 ) would do that and i could remove
a relay under dash to the left of brake pedal switch it with another one and it would work . I dont remember wich one it was . Good luck . :rockin
 

·
Registered
Joined
·
726 Posts
Discussion Starter · #7 ·
Hey thanks thats a start I'll check that out real quik.
Thanks Farmer
 

·
Registered
Joined
·
47 Posts
Looked at my 05 . Theres a 30 amp cb for the seats . I didnt remember my 03 being like that . Wont take long to check it out though .
 

·
Registered
Joined
·
726 Posts
Discussion Starter · #9 ·
I looked at I think your right its the 30 amper my buddy has my ohm meter otherwise Id test it but Ill just stop by AutoZone and grab one and pray it works lol.
 

·
Registered
Joined
·
924 Posts
:help my 03 is doing kinda the same thing. the power seats works but when i turn on the seat heat on either side it only stays on for a few seconds and then cuts off. is there a relay i need to track down? i called myself looking in the manual and found one (sb01 i think ) but it called it a rear seat heat, which i dont have. guess its for several models. guess im gonna start by turning it on and off and tracking down the clicking noise till i find it and try a new one. just windering if someone has had this problem and if yall may know where the relay may be located, if that is the problem.
 

·
Registered
Joined
·
47 Posts
bamadiesel . Either the element in the seat is shorting out somewhere and causing it to pull to much juice and shutting itself off or your bcm could be the problem but most of the time its the element .
 

·
Registered
Joined
·
924 Posts
but they are both doing the same thing? i can tell the drivers side has been put to use because the seat picture on the button is wore but the passenger side looks new. what is the bcm?
 

·
Registered
Joined
·
47 Posts
Bcm is body control module sometimes dealer reprogram of this will fix the problem . does the passenger seat heater work if you just turn it on by itself ?. I have heard if the driver seat has a bad element it can shut both off when you turn it on but your passenger one should work by itself I think if its bad element in drivers seat . Im no expert though just my experience with em .
 

·
Registered
Joined
·
924 Posts
yep, thats exactly whats happening. passemger works fine but when i turn on drivers they both shut off
 

·
Registered
Joined
·
47 Posts
Omeara did that work for ya ?
 

·
Registered
Joined
·
47 Posts
Bamadiesel sounds like driver side element .:(
 

·
Registered
Joined
·
726 Posts
Discussion Starter · #17 ·
Farmer its funny you ask. I haven’t touched it but just started working on its own again. I don’t know what to think about it so the mystery continues. :drink
 

·
Registered
Joined
·
924 Posts
is it hard to change?
 

·
AKA treyfox11
Joined
·
2,250 Posts
hey at least yours isn't doing what mine is it just comes when it wants i will riding down the road and all of a sudden my rearend is on fire lol
 

·
Registered
Joined
·
188 Posts
My driver heated seat only works on the back part. And even its now starting to work for a bit then cut off but the passenger side works fine. But my really wierd problem is on my power seat controls. When you move the seat position button forward my seat moves back and vice versa. That really boggles me. But hey at least it still works...right?
 
1 - 20 of 20 Posts
Top