Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
Joined
·
164 Posts
Discussion Starter · #1 ·
The dealership where I bought my LMM said that he would sell me a PPE. Would this really help my fuel mileage, I pull a 16ft landscaping trailer daily, and I need some help QUICK to get some better MPG!I dont need any more power, these LMMs are strong! I am gonna keep this truck until it wont pull another day, I dont want to put anything on here thats going to hurt the engine, trans ect..Also, if my truck ever had any warranty recalls,repairs ect, would they be able to tell that I had a box on it? Seriously men, I need better fuel mileage, what I have heard, some of these programmers,downloaders ect, will only help MPG MAYBE 2 mpg,is that true? Thanks in advance for all of your help! ALL INPUT GREATLY APPRECEIATED!!!!!!!!!!!!!!!!!!!!!!!!! Jim B
 

·
Diesel Addict
Joined
·
7,754 Posts
with a PPE and exhaust i gained 2.5 to 3mpg on my LBZ witch is a LMM minus all the EPA crap and on my LLY i gained 5MPG doing a exhaust CAI and the PPE programmer..
 

·
Registered
Joined
·
5 Posts
I first bought the PPE chip and put it on my truck with 500 miles on the truck. After driving it about a week it went into the "limp-mode" I have been reading about and I drove it around for about 2 weeks like that. I put it back to stock and took it to the dealership and they cleaned out the exhaust filer and it was good as new. I put the upgraded software on the chip and have put it back on my truck. Every so often (maybe once a week) it will do the limp-mode thing again but after I shut the truck off or sometimes if I stop, it will usually go back to the performance mode I had it tuned too. Does anyone else have this problem that has the PPE chip and if so, why is it doing that? Is it bad for the truck? Thanks.
 

·
Registered
Joined
·
2 Posts
Ppe

I have a PPE Xcellerator......4 levels and now just bought the HOT add on. I have had it on all levels since about 5000 miles, I now have 16k.....it has never missed a beat, performed flawlessly thoughout. I too feel it is weak on the lower levels. No problems switching it back to stock either:)
 

·
Registered
Joined
·
47 Posts
I first bought the PPE chip and put it on my truck with 500 miles on the truck. After driving it about a week it went into the "limp-mode" I have been reading about and I drove it around for about 2 weeks like that. I put it back to stock and took it to the dealership and they cleaned out the exhaust filer and it was good as new. I put the upgraded software on the chip and have put it back on my truck. Every so often (maybe once a week) it will do the limp-mode thing again but after I shut the truck off or sometimes if I stop, it will usually go back to the performance mode I had it tuned too. Does anyone else have this problem that has the PPE chip and if so, why is it doing that? Is it bad for the truck? Thanks.
Yes the limp mood problem with the lmm is not only me anymore. I have had the same problem with the lmm not my other lbz. What i do clear all codes and the limp mode goes away. I have had this problem while towing and ripping on it around town. We are triyng to get rid of all the filters and straight pipe this truck so maybe this will help but time will only tell.
 
1 - 5 of 5 Posts
Top