Chevy and GMC Duramax Diesel Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
When I installed my PPE programer with the setting on "2" 90HP additional, I get a very noticeable rattle when it launches. I really notice it from a dead stop and gun it. It will leap with no turbo lag but it sounds like detonation.

My buddy just got a Hypertech for his LBZ and he has no "rattle" with his on setting 2 but he doesn't have the take off power I have.

Can anyone shed some light on this? I'm concerned I may be causing some premature damage to my motor. I dropped the setting down to 1, it's not as bad but rattle is definitely there.
 

· Registered
Joined
·
29 Posts
Discussion Starter · #4 ·
i have the ppe hot et the highest setting is 300hp 460tq,it will really run on the high setting but the transmission really hates it.i never had any problems with it,i've had it now for little over 20,000 miles.
Did you notice a destinctive "rattle" after installing it? I'm nervous because it does sound similar to a Cummins. Not as loud but definitely noticeable.
 

· Registered
Joined
·
29 Posts
Discussion Starter · #6 ·
Thanks BK. I really like this truck and don't want to prematurely break it. I was told the use of a programmer will void the motor warranty. Even if you return the motor back to stock settings prior to takeing it in, a GM programmer can see the trucks stock programming was changed.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top