Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 4 of 4 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
I look down and spit and spit on the ground every time my truck is mentioned. I'm sorry people but this thing is a POS !

Todays Codes: (cuz we gotta have codes everyday)

P0380: always have this one but the glowplugs are good.
C0550: Cuz a tow driver squished the wiring to the right rear ABS
P0404: I'm told a $55 sensor to fox no biggie
FRESH ONES:

P0843
P0700
Tranny went into limp mode "Shift Range Prohibited". I cleared the codes and drove the truck. Are these just more nuisance codes or is there something of immediate concern?

P01404: I'm told same fix for P0404

The speedo sticks on the freeway every time I travel over about fifty or so miles. There are like two dozen guys on e-bay making a living rebuilding those clusters for about $120 a pop.

Now I need your opinions. Is this bs something that just goes with territory on the trucks or is mine truly just a freak POS? It has 118k on it. Will I ever be able to catch up on this or is it just the way it is? If I upgrade to a later model (LLY,LLM) will this shit go away? Or are these things like Jaguars and you have to dick with them? I just want to fire up my truck and go...I'm not into the code chasing thing anymore..it's no fun anymore (LOL).

I bought the truck to tow my 36' fifth wheel but the trailer is pretty much stationary in an RV resort right now. So I don't plan on towing heavy stuff anymore. Basically I could use just a HD 6.0 or even a 1/2 ton. I use a truck for homeowner stuff and recreation that's it.

OK...do we ever catch up on this stuff? If not do I dump it for newer Duramax or a gas truck?

Thanks For Your Opinons,

Larry
 

·
Registered
Joined
·
686 Posts
At least for that EGR crap, the solenoid regulator vent valve part number 1997254 should take care of your p0404, 1404. As far as the p0380, I'd check them at the glow plug module. Maybe there is a bad connection or wire to one of the glow plugs.
I fixed my cluster myself by replacing the stepper motors. I have had these problems too and fixed them easily myself and no problems now.
Not sure on the p 0843 and 0700 but the other ones are easy.
 

·
Registered
Joined
·
1,920 Posts
I'd buy a 6.0 ford...that should fix all your problems!
 

·
Registered
Joined
·
686 Posts
I'd buy a 6.0 ford...that should fix all your problems!
:rof
You mean exchange them for a whole set of new ones...
On another site, one guy was saying he got 35 MPG with his '04 Excursion with 6oh and that is only because he was towed most of the time.
 
1 - 4 of 4 Posts
Top