Chevy and GMC Duramax Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have the factory elevated idle turned on, this morning before leaving for work i started the truck to warm up and it idled normally with no elevated idle active ECT was about 55 and Intake air temp was 40. After leaving and driving about 3 miles the truck was at 143 ECT and Intake air temp at 43. When i got to my destination and parked the truck, the elevated idle kicked if for about 5 seconds the kicked right back off and idled normally. This is the first time this truck has done this since i've owned it. should i be concerned or be looking for any issues? i appreciate the insight in advance guys! Also all temp readings were directly from the Edge Insight
 

·
Former GM Tech and parts
Joined
·
2,877 Posts
I wouldn't worry anything about it. Seems like here in the last couple weeks, mine has acted funny a couple times, but the temps and weather have been doing some crazy stupid stuff all over the place. The only time I worry about it is when its actually cold and there is no reason for it not to work but it doesn't kick on.
 

·
Premium Member
Joined
·
1,092 Posts
Yeah my truck does that too.. Will idle normal at cold startup but then if I take a short drive and park again it will idle up for a few seconds sometimes.

Sent from my SM-G977U using Tapatalk
 

·
Registered
Joined
·
1,686 Posts
Sounds like really odd behavior.

Here's a video and a description on high idle.

My experience is that it will never kick on above 32 degrees or so, and for sure not when the ECT is already 140+

 

·
Registered
Joined
·
56 Posts
That's normal. Example of this, my LMM will idle up when I get 2 miles down to my coffee stop on a regular basis after doing a full elevated cycle at home. Totally normal.
 

·
Registered
Joined
·
743 Posts
That wasn't normal idle when he stepped on the brake :p It was doing a regen. Normal idle is about 150-200 RPM slower than that.
 
1 - 6 of 6 Posts
Top