Chevy and GMC Duramax Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
Ok, im really beginning to wonder if my truck isnt possesed or something. ever since i bought my truck my tow haul mode button, when pushed, has not worked.. here lately, randomly, it comes on when I start the truck, it will randomly come on and I dont even push the button, I have no clue what in the world is going on... anyone have any clues? ... also... My tachometer quit working... ive switched out every single stepper motor, they all work, but the tach still shows 0 .. is there a sensor or plug somewhere i need to check, cause once again im clueless.. any help will be greatly appreciated...
 

·
I'm That Guy...
Joined
·
16,690 Posts
I'd use a v2 or something to monitor rpms via obd2 port to see if sensor is working, I bet it is. Then next step would be to try a different gauge cluster.

As for the tow/haul, I'll leave that to someone else. My guess would be shifter, switch, or something along those lines, but those are 100% guesses.
 

·
Registered
Joined
·
1,167 Posts
I vote spook!!!! You better find a voodoo witch before Halloween night or your truck will become a 150hp turd and get 3mpg!!
 

·
Registered
Joined
·
73 Posts
Discussion Starter #4
Lol!... it probably will become a 150hp turd.. the tow haul mode was the orange wire on the column where it pivots as u pull the shift back ... the wire broke completely in half and was floppin around, probably would make contact with the other part of the wire that was stationary.... got that fixed... now on to the tach.. gonna have to find someone who does tuning around here and get them to see if the sensor that reads rpm is working...if it is.. ill just snag another cluster...
 
1 - 4 of 4 Posts
Top