Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 19 of 19 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I have an 03 Duramax. Have been getting the error message "Range Shift Inhibited" when I go into reverse, have to put it back in park until it decides to go into gear. I have had the tranny serviced and replaced the NSBU switch. It is still giving the error "Range Shift Inhibited" and my tranny slips randomly. When put on a scanner it shows no codes. This has been going on for a few months & have had it to several shops that specialize in Alison transmissions- they are baffled. The tranny is mechanically sound- can anybody help?!?!?!
 

·
Oh...... Squirrel!
Joined
·
24,083 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Thank you for the advice. I replace the speed sensors- but did not fix problem.
"Range Shift" Inhibited" still comes up and tranny slips in 4th gear only. When hooked up to scanner it still shows no error codes. I have a gremiln somewhere in the electrical components but cannot find it. Has anybody else ran into similar problems?
 

·
Oh...... Squirrel!
Joined
·
24,083 Posts

·
Registered
Joined
·
378 Posts
You might try a serch on this cause I know there is a thread on the DF with a DIY video or pics link for changing the ingnition switch.
 

·
Premium Member
Joined
·
17,806 Posts
Very easy to change-- pull the lower cover from the steering column- (under where where the key is) The switch is there-- a square box with wires. Press a couple plastic tabs and pull the switch down-- then disconnect the wire connector.

Connect the connector to the new switch, place the key to the on position and slide the switch in.

Note- the new switch is set to on, so if you have the key lock to on, and slide the switch in, it should be indexed correctly. If you cannot turn the key to start, you have it indexed incorrectly.

Hope this helps, Jerry
 

·
Oh...... Squirrel!
Joined
·
24,083 Posts

·
Premium Member
Joined
·
77 Posts
I've also heard the ignition switch being the culprit.
 

·
Registered
Joined
·
10 Posts
Durmator, did you ever get this fixed? I have as similar issue but everything is fine with the transmission. It was running great until i changed the filters and transmission oil. All of a sudden i get this Range Shift Inhibited message and transmission slips. I know there is nothing wrong but something silly for sure. Please let me know what you found out.
 

·
Registered
Joined
·
34 Posts
Very easy to change-- pull the lower cover from the steering column- (under where where the key is) The switch is there-- a square box with wires. Press a couple plastic tabs and pull the switch down-- then disconnect the wire connector.

Connect the connector to the new switch, place the key to the on position and slide the switch in.

Note- the new switch is set to on, so if you have the key lock to on, and slide the switch in, it should be indexed correctly. If you cannot turn the key to start, you have it indexed incorrectly.

Hope this helps, Jerry
Help. Have parts but also have a tilt steering wheel. Cant seem to figure out how to remove cover
 

·
Registered
Joined
·
22 Posts
Msudmax,
I have an o
05 dually with same thing. That cover just unsnaps. Had to do this 3 yrs ago and just this morning same thing. Mine both times had been the electronic part of the ignition under that bottom cover. It pulls apart top and bottom but is a pita. Hope u got it figured out by now but if not that is how it comes apart.
 

·
Premium Member
Joined
·
5,057 Posts
I’m currently having this issue if anyone knows the solution please PM
this is an OLD thread, Post prior to yorus was in 2020, the one prior to that 2013. You are not likely to find an answer here on this thread. Search the forum for more threads
 
1 - 19 of 19 Posts
Top