Chevy and GMC Duramax Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 2016 3500 4x4 duelly with 25000 miles that every time except the first I tow it sets C0045 (right rear wheel speed signal erratic). And now it is setting sooner and also setting C0050 (left erratic) The dealer has previously replaced the right sensor with no affect. The next time I tow as always it goes through a traction control event at highway speeds modulating brakes and in one event almost causing a complete loss of control. The red brake,ABS,Stabilatrak and only the last time the trailer brake warning lights come on. The dealer has had the truck over two months this time. I am a A.S.E. Master auto and light truck technician and completely believe the problem is in the rear differential. The ABS tone rings are at the side bearings of diff. ever since this 11.5 inch diff. was updated in 2015. The first time I did the oil change after the two free I found a glob of oil metal mixture the size of a large jaw breaker on the fill plug magnet. I do not wish to incur the cost of doing this myself since it is still under warranty. HAS ANYBODY SEEN THIS OR ANYTHING LIKE THIS. It does not have any communication U codes as with TSB PIT5569A.
 

·
Registered
Joined
·
1,530 Posts
. The ABS tone rings are at the side bearings of diff. ever since this 11.5 inch diff. was updated in 2015. The first time I did the oil change after the two free I found a glob of oil metal mixture the size of a large jaw breaker on the fill plug magnet.

If your differential fill plug had a large accumulation of oil metal mixture, is it possible that this same material (or some other material) has also found it's way to the ABS tone rings and this causes an erratic signal? Perhaps just cleaning the tone ring, or replacing if necessary, is the fix. And if you don't have good WSS signals, the ABS system can't function, and that in turn sets stabilitrak, trailer brake system, etc warnings.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
This is something along the lines as I also was thinking. The odd thing is it only happens when towing a medium large travel trailer. And only after 100 miles. It does seem to be getting worse, it was happening only after 250 to 300 miles. As to cleaning or replacing the tone rings since they are serviced from inside the differential and the diff carrier will have to be removed I was hoping someone else had seen this to have more ammunition with the dealer. They claim to have contacted GM technical line although I am a skeptic. As far as I can tell my truck has not moved in four weeks. When asked if the diff cover ha been removed for inspection they stated they would get back with me.That was nine days ago. Tomorrow I plan to escalate with the dealer. And if necessary GM. I was thinking I can not be the only one with this issue.
 
1 - 3 of 3 Posts
Top