Chevy and GMC Duramax Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,680 Posts
Discussion Starter #1
So i have gotten lots of things fixed and more things have appeared to be wrong. It seems as one problem is solved i find another that i over looked. A quick run down is bent sway bar end links, bad front hubs, bad speed sensors, bad vibrations (IDK), rear end seal is gone and spraying rear end fluid, trans is heating up to 200 degrees, trying to stack gears in the higher gears, loosing coolant somewhere.

So on to the coolant problem. My coolant tank is not nearly as black as it has been. The oil is kind of grey looking and extremely burnt. The trans fluid is normal. Radiator hose is semi soft, but the coolant resi holds lots of pressure, drinks coolant down to a certain level and then stays there. It doesn't go any lower than what it currently is. But as soon as i fill it up it starts loosing again. I see no more leaks. All of them have been fixed. I have pressure tested the system and nothing happens. The only other four things i can think of is A) headgasket B) injector cup or C) water pump or D) oil cooler. I was told if the oil cooler was leaking then it could cause these problems. The engine temp hovers around 200-210 at all times no more or less.

Transmission.... Obviously wasn't built right. The trans builder has got to fix this problem but what can i do in the mean time to keep it cool other than not drive it? The temp stays right at 200 all the damn time.

I have a 600 mile round trip planned for tomorow. And i look for atleast one of these things to happen to me. I pray it doesn't but it is possible.

A) one of my wheels and tires come off and passes me going down the interstate
B) the motor over heats
C) the trans over heats
D) the rear end welds itself together
E) I get a speeding ticket

I am just so scared that one of these things is going to happen and all i can do is pray. I don't have the cash currently to fix it all.

Oh and just today i spent a little over 100 on a fuel filter and water seperator sensor thing. Both of them were split. ARGH!!!

So What is you thoughts on all of these things
 

·
Registered
Joined
·
1,486 Posts
When it rains it pours.... Sorry to hear about your misfortune... IDK I think I would try to fix the motor probs first seems how they might be more urgent/more expensive down the road... Good luck.
 

·
Registered
Joined
·
1,680 Posts
Discussion Starter #3
Welll....... I made it about 20 mins from my house before my u rear tire started wobling. Tighten the lug nuts that help some. 5 more mile i got a violent vibration and floating rear end. Looked and found that 2 bolts were missing from my u bolts holding on my leaf springs. I still had the death woble so i decided to drive home. My Mom meet me and followed me. Well the u Joing busted along with the rear end yoke!
 

·
Registered
Joined
·
1,680 Posts
Discussion Starter #4
$1098.36 WORTH OF DAMAGE!!!!! Only 120 of it is labor and the rest is PARTS!!!! FML!!! I don't have that kind of cash!
 
1 - 4 of 4 Posts
Top